How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Wilson Your Own Question
Daniel Wilson
Daniel Wilson,
Category: Medium and Heavy Trucks
Satisfied Customers: 5587
Experience:  Owner at DJ Wilson
65405794
Type Your Medium and Heavy Trucks Question Here...
Daniel Wilson is online now
A new question is answered every 9 seconds

Yesterday my speedometer, odometer, voltage gauge and

Customer Question

Yesterday my speedometer, odometer, voltage gauge and instrument light cluster stopped working. Checked fuses and relays in fuse box as well as relay directly behind gauges. Could not resolve the problem.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Daniel Wilson replied 1 year ago.

Hi, My name is***** will be glad to try to help but what is the year make and model of your truck?

Customer: replied 1 year ago.
Speedometer,odometer,voltage guage and instrument light cluster quite working. Checked fuses snd relays in fuse box and behind instruments.
Customer: replied 1 year ago.
That's the problem
Expert:  Daniel Wilson replied 1 year ago.

Is this you?

Customer

I have 2.65v on pin 11

27 Jan 2016, 10:41 AM

Me

Hi, You have 2.65v on pin 11 on what vehicle? were you working with someone on an existing question? this is a new question that was posted?

27 Jan 2016, 10:44 AM

Customer

2001 Pete 379 6nz c15. I only have 2.65v on pin 11. 12v at the override switch. I have cat et, if that helps.

Expert:  Daniel Wilson replied 1 year ago.

Click on these links for the schematics.

Schematic 1

Expert:  Daniel Wilson replied 1 year ago.

Engine schem

Let me know if you need more help

Customer: replied 1 year ago.
I think you hsve the wrong customer
Expert:  Daniel Wilson replied 1 year ago.

Here is the link to the other question and they are both opened by you. You have two open questions for this same problem. Is this a 2001 Pete 379 6nz c15 ?

http://professional.justanswer.com/chat/index/e32f8537ec3f4475a44539584f01b4ca#

Customer: replied 1 year ago.
This is not my question. I have 2004 peterbilt with instrument problems.
Expert:  Daniel Wilson replied 1 year ago.

Must be something weird going on with the site.... I will be glad to help you. What is the chassis model?

Customer: replied 1 year ago.
2004 peterbilt. speedometer, odometer, voltage gauge and dash warning light cluster all stopped working at the same time. Thing this could be a relay, however could not find the problem.
Optional Information:
What Have You Tried So Far?: Checked all fuses. Checked relays in fuse box and behind instrument panel.
Expert:  Daniel Wilson replied 1 year ago.

What chassis model Peterbilt do you have? Is it a 379, 387, 335, 348, 359, 362. etc? Each model will have different wiring to the gauges. I need to know what model Pete you have so I know what schematics to look at to help you.

Expert:  Daniel Wilson replied 1 year ago.

If you do not know look at the tag on the door post and let me know

Customer: replied 1 year ago.
379 chassis
Expert:  Daniel Wilson replied 1 year ago.

Ok great, Click on the first link I posted. You will see the instrument power and ground connector. Test for power and ground to the gauges. If there is power/ground there and the datalink harness checks good it means the cluster has internal problems.

Wire number 239 Inst ground

253 Inst light power

242 Inst power

Expert:  Daniel Wilson replied 1 year ago.

http://www.instrumentclusters.com/

This company will test, inspect, repair, and warranty your instrument cluster if found to be faulty. Let me know

Expert:  Daniel Wilson replied 1 year ago.

Hi, Did you get this resolved?