How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jeremy Your Own Question
Jeremy
Jeremy, Certified Truck/Bus Technician
Category: Medium and Heavy Trucks
Satisfied Customers: 3304
Experience:  ASE Med/HD Truck Technician, NATEF Diesel Engines and Electrical/Electronics Technician, EPA 608/609 HVAC Certified, Steering/Suspension and ABS/Brakes Technician
9290743
Type Your Medium and Heavy Trucks Question Here...
Jeremy is online now
A new question is answered every 9 seconds

I have a 2002 Freightliner FL60 with an Allison Automatic

Customer Question

I have a 2002 Freightliner FL60 with an Allison Automatic transmission. After sitting for about 4 - 6 months, I fired it up to move it and the "Check Trans" light was on. When I put it in to gear the "Range Inhibited" light comes on as well. It does not
go into gear forward or reverse. I have changed the Neutral Safety Switch and the ignition switch and still nothing. There is a fuse on the panel that where I pull it out, you hear something engage but still does not move. Before sitting, it ran great. I did
notice it was hard to shift in to gear the upon first starting after the 4-6 months. It had a good resistance. Now the gear selector moves fine. I've also heard about the transmission control module but I do not know where that is.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  Jeremy replied 1 year ago.

My name is ***** ***** I will assist you.

Have you checked the fluid and changed the filters, both in and out on this? usually when these sit for awhile, the fluid will gunk up and it will create sludge and cause the filters to plug and the pump to plug up.

With the range inhibit, it won't shift into gear. The transmission is in limp mode. Which shifter do you have? If it is the button style, push the up and down arrow at the same time with the key on, engine off, and you will get codes that will come up on the display. Give me those codes and I can tell you if there is something else going on.

To reset those codes, after you have the codes come up, press and hold the mode button for 10 seconds minimum. You will hear a set of beeps, but keep holding the button until you hear the second set of beeps. That means the codes have cleared and then see if the vehicle will move.

CLICK HERE for more info for code retrieval and reset.

__________________________________________________________________________________________________________________________
You want a 5 star service and I want to provide a 5 star service. Please consider that I don't know your skill level as well as I can't see,
touch, smell, hear the vehicle/machine in question. Please provide as much detail as possible and I will provide as much back.

Once an answer is provided, you should see a rating screen. Please rate my personal service to you. The ratings are my personal feedback,
they are not the site feedback.

Thank you for allowing me to assist you through Just Answer!

Jeremy

Customer: replied 1 year ago.
Thanks for the reply. I'm on Guam so the time difference is a problem. I got your reply late last night/early morning. Being that it ran fine previously, we have never addressed fluid or filters. We will start looking in to that as a cause.This truck is using the normal shift lever on the side. I checked the codes and then tried to clear them and run the truck. It still did not engage. Codes that show up are:ABS 136 - which was there when we bought the truck.
Not knowing how to check the other fault codes, I do not know if the rest of these have been there for a long time, they are:
Sid 251
Sid 054
FAIL 05The ABS, 251 and Fail 05 reappears immediately after you reset the codes and check it again. Whether or not I started the truck. The Sid 054 does not come back after resetting, but it did come back after starting and shutting off the truck.
Expert:  Jeremy replied 1 year ago.

The 54 05 code is battery voltage error issue. There is a short on the batteries or in the harness from the batteries. Check the connections over real well. Also check over the harness at the ECM.

The ABS code is another voltage code issue going to the ABS module. Again, the connections need to be checked coming off the batteries.

So far you have 2 codes for that which is telling me you have a battery voltage, cable, or alternator power problem. Load test the batteries to make sure there are no dead cells in the batteries. Then check the power box under the hood for corrosion. Make sure there is no corrosion built up and causing a low voltage, high amp pull which would cause the issues you have.

Expert:  Jeremy replied 1 year ago.

If you don;t have the push button style shifter, your only option might be to connect a Allison scanner to the truck to see what it is doing. Allisons are extremely hard to diagnose without the codes or scanner hooked up.

Expert:  Jeremy replied 1 year ago.

I see you viewed this and this is still showing as a open question due to no positive (3 stars or more) rating.

Did you still need assistance with this?

Related Medium and Heavy Trucks Questions