How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Wayne Your Own Question
Wayne
Wayne, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 9676
Experience:  worked on, Gmc, Macks, Freight liner,Mercedes Benz,,Ford, sterling
6825259
Type Your Medium and Heavy Trucks Question Here...
Wayne is online now
A new question is answered every 9 seconds

No power on my f750 with 5.9

Customer Question

No power on my f750 with 5.9
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Customer: replied 1 year ago.
Also making knocking get noise from clutch area but goes away when turning right
Customer: replied 1 year ago.
Hello
Customer: replied 1 year ago.
Could it be the lift pump ?
Expert:  Wayne replied 1 year ago.

Hi I'm Wayne

I will help you with this

I see you been waiting awhile,

do you still need help with this

let me know

Customer: replied 1 year ago.
Customer: replied 1 year ago.
Hello
Expert:  Wayne replied 1 year ago.

Morning

when you say no power, is loosing power hitting a hill

or just all the time

Customer: replied 1 year ago.
Hitting a hill
Customer: replied 1 year ago.
It seems to idle fine,runs smooth at idle and as u rev it up
Customer: replied 1 year ago.
Loud clacking noise at around 60km
Expert:  Wayne replied 1 year ago.

Thank you for that

That sounds like a turbo boost sensor

or loose hoses for turbo,

check all the ductwork from air to air to turbo,

make sure no loose clamps, or hoses,

if all OK, then boost sensor, it is mounted in the valve cover

with 2-3 wire harness

Hi if this helped you

Please rate my answer 3 or more stars

If you need more info, use request button

Not Poor/Bad service

Customer: replied 1 year ago.
Empty I can get a 100km out of it
Customer: replied 1 year ago.
I will check that
Expert:  Wayne replied 1 year ago.

Thank you for that

Yes that is a turbo issue

check the things I have mentioned

Hi if this helped you

Please rate my answer 3 or more stars

If you need more info, use request button

Not Poor/Bad service

Customer: replied 1 year ago.
Ok thanks Ya it sounds like it's getting no boost
Customer: replied 1 year ago.
I will check
Expert:  Wayne replied 1 year ago.

Hi

Yes that is where I would put my money

Please remember to rate my answer so I get credit for question

Customer: replied 1 year ago.
It's a 5.9 cummins just to clarify
Customer: replied 1 year ago.
Ok thanks
Expert:  Wayne replied 1 year ago.

your welcome

Customer: replied 1 year ago.
Another question what can I buy to get more power out of this truck like 100hp
Customer: replied 1 year ago.
The motor has 20000 km on it, it was replaced by cummins
Customer: replied 1 year ago.
2 years ago but I tow a trailer and a machine on it and there is no power
Customer: replied 1 year ago.
Different turbo or injectors ?
Expert:  Wayne replied 1 year ago.

Hi

Let's work on the power issue 1st

you will never get a 5.9L higher than 290 Hp

Expert:  Wayne replied 1 year ago.

Yes injector replaced, and injection pump turned up

Customer: replied 1 year ago.
Why is that my pickup 5.9 is 325hp with a bigger turbo and chip it's around 430hp
Customer: replied 1 year ago.
I thought 5.9s can produce big power
Customer: replied 1 year ago.
I will work on the issue first but please let me know why you can't spice up these 5.9s
Expert:  Wayne replied 1 year ago.

Hi

Truck and RV 5.9L are different stroke the Pick ups

Customer: replied 1 year ago.
I can't see a sensor on the valve cover
Customer: replied 1 year ago.
Can u tell me where I took a pic
Expert:  Wayne replied 1 year ago.

Hi

I see it is not on the valve cover of that model

here is a pic of it

click here

Expert:  Wayne replied 1 year ago.

HI

It is also called a MAP sensor

sensor located in the intake manifold next to cylinder #5. To replace it you simply unplug the wire running to it, unscrew it to remove it, screw the new sensor into the manifold and plug it back in

Customer: replied 1 year ago.
How sure are u that its the map sensor ,no hoses are leaking
Customer: replied 1 year ago.
What would cause the loud noise at 60km
Expert:  Wayne replied 1 year ago.

Hi

I am 100% sure of MAP sensor

lets fix this 1st, then get to your 2nd question

Wayne

Hi if this helped you

Please rate my answer 3 or more stars

If you need more info, use request button

Not Poor/Bad service

Customer: replied 1 year ago.
Still making the same noise then no power after changing the map sensor
Expert:  Wayne replied 1 year ago.

Morning

The loud noise, it it like a squeal,a pop or like a air rush noise

Let me know

Customer: replied 1 year ago.
A air rush almost like a ball bearing that's really bad
Customer: replied 1 year ago.
I wonder if the waste gates stuck
Expert:  Wayne replied 1 year ago.

Thank you for that

OK, we are narrowing down

with that noise description

Yes, that is what I am going to suggest

to replace it,

but that does not explain goes away turning right

but will give lack of power

Hi if this helped you

Please rate my answer 3 or more stars

If you need more info, use request button

Not Poor/Bad service

Wayne