How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask spankyjr1 Your Own Question
spankyjr1
spankyjr1, Journeyman
Category: Medium and Heavy Trucks
Satisfied Customers: 2598
Experience:  I worked on all types of equipment semis,forklifts,farm,ect.
65057319
Type Your Medium and Heavy Trucks Question Here...
spankyjr1 is online now
A new question is answered every 9 seconds

I have a 2006 volvo vnl 670 with a manual 10 speed meritor

Customer Question

I have a 2006 volvo vnl 670 with a manual 10 speed meritor transmission. When I am loaded and it is hot outside when I hit the splitter on the gear shifter the transmission will not go into high or low. It stays in high range. I already changed the solinods on the trans and also the gear shifter nob . It still is doing the same thing but when I pull over for 20 min and things cool down even with the engine at idle it will start to go in high to low range again and work fine.
Submitted: 1 year ago.
Category: Medium and Heavy Trucks
Expert:  spankyjr1 replied 1 year ago.

Hi Thanks for your question my name is spanky.

First check air pressure to trans just to make sure you don't have low air pressure as some trucks gage will show good air supply

but they have check valves inside air tanks that go bad,, if the trans is on bad side it will cause problems like this.

Next This sounds like it is a low voltage issue,,what happens as things heat up you don't have enough amps to complete the shift.

Next to trans is a 6-8 way plug that has all your power and grounds for trans,,you want to check that harness all the way back to

batteries.

You need to clean all battery positive/negative connections including frame, starter, and engine.

Most times this is the issue.

If you run into trouble let me know I'm happy to assist.

FYI I will be out for a few hours if you end up needing anything else follow ups are included after rating so no worries.

Customer: replied 1 year ago.
I checked the wiring harness on the transmission and I cleaned the battery cables. Today the issue didn't happen it seemed to work fine hopefully it will continue to. Keeping my fingers crossed. Thank you !
Expert:  spankyjr1 replied 1 year ago.

You are very welcome friend.

Let me know if you have anymore trouble I'm happy to assist.

Please don't forget to rate my service so I get credit from the web site.

Take care

spanky

Expert:  spankyjr1 replied 1 year ago.

I'm just following up to see if we resolved the issue or you need more info.
I would appreciate a reply so I know you are happy with my assistance.
Thanks
spanky

Related Medium and Heavy Trucks Questions