How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Michael Hannigan Your Own Question
Michael Hannigan
Michael Hannigan, Engineer
Category: Marine Electronics
Satisfied Customers: 11865
Experience:  25+ Years Experience in Field. Master Certified Electronics Tech and Technical Consultant
23511658
Type Your Marine Electronics Question Here...
Michael Hannigan is online now
A new question is answered every 9 seconds

I have a LC X-111c unit with an Type MDS-1 radar unit. I cannot

Customer Question

I have a LC X-111c unit with an Type MDS-1 radar unit. I cannot get the radar to power up. I go to the radar menu, then radar power and set it at power on. A message comes up stating to power on or off. No sure what to do.
Thanks,
James Shelton
Submitted: 2 years ago.
Category: Marine Electronics
Customer: replied 2 years ago.
I am not experienced with this unit. Maybe I am not powering up the unit correctly.
Customer: replied 2 years ago.
(Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 2 years ago.
James Shelton(###) ###-####
Expert:  Michael Hannigan replied 2 years ago.
Hello. My name is Michael. I can help you with your question. The radar should have a red and blue wire that goes to a power switch. Do you have that wiring connected?
Customer: replied 2 years ago.
The units where professional installed so I do not think there is any connection problem. Either the radar unit has failed or I am not following the correct start up procedures. Can you please send the detailed but "dummy" instructions to boot the radar up.
Thanks, ***** *****
Expert:  Michael Hannigan replied 2 years ago.
There's really nothing special that you have to do to turn it on. Once it's installed, all you should need to do is have the radar physically turned on and it should be recognized. The reason you're getting that message is that it doesn't see the radar unit for some reason. In fact, it doesn't even really matter what order you turn them on in.
It is possible that it's not set up for the port that it's connected to, but I would assume that the did that when it was installed. So I would be a little bit hesitant to change those settings. But but it is something that can be configured. This could actually make the situation worse so I don't necessarily recommend doing this. But I'm providing it in case you decide you want to experiment with the configuration. There should be a switch wired for the radar, are you certain that the physical switch is turned on?
1.From the Chart page, press [MENU]. Move the ShuttlePoint knob to highlight SETUP
MENU and press [ENT].
2. Move the ShuttlePoint knob to highlight ADVANCED SETUP and press [ENT].
3. Move the ShuttlePoint knob to highlight IN/OUT CONNECTIONS and press [ENT].
4. Move the ShuttlePoint knob to highlight PORT 1 INPUT and press [ENT].
5. Move the ShuttlePoint knob up/down to select RADAR and press [ENT].
6. Press [CLR] or move the ShuttlePoint knob to the left until the Chart page is shown.