How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ashik Your Own Question
Ashik
Ashik, Mac Technician
Category: Mac
Satisfied Customers: 11193
Experience:  Bachelor of Computer Application (BCA), 9+ Years of Experience in troubleshooting Macs, iPhone, iPad, iPod etc
16433418
Type Your Mac Question Here...
Ashik is online now
A new question is answered every 9 seconds

I need the older version of Skype for my Mac Book Snow

Customer Question

I need the older version of Skype for my Mac Book Snow Leopard 10.6.8 I had it and then somehow I got booted off. Skype made me download the newer version which is not supported by my laptop
JA: When did you last update your Skype?
Customer: I've never updated! ;(
JA: Anything else you want the software expert to know before I connect you?
Customer: Is there a fee?
Submitted: 2 months ago.
Category: Mac
Expert:  Bryan replied 2 months ago.

Hi, my name is ***** ***** I'll be assisting you today.

Skype recently did an update that will only offically support Mac OS X 10.9 (and later versions) from now on. However, there's a workaround we will be able to carry out to patch Skype to work with your OS version as well.

Can we go ahead with a secure remote session so that I can walk you through the steps for the same?

Please reply at the box below; thank you.

Customer: replied 2 months ago.
Customer: replied 2 months ago.
don't want to securely connect
Expert:  Bryan replied 2 months ago.

Please ignore any remote assistance offer (simply "X" it out) shown on this page; it's sent by our site and not by me. Can we go ahead with a FREE remote session instead?

Customer: replied 2 months ago.
will you still help me?
Expert:  Bryan replied 2 months ago.

Please ignore any remote assistance offer (simply "X" it out) shown on this page; it's sent by our site and not by me. Can we go ahead with a FREE remote session instead? The reason I ask is, the steps will be too complicated to follow via this page itself.

Customer: replied 2 months ago.
Customer: replied 2 months ago.
ok
Expert:  Bryan replied 2 months ago.

OK, let's get started with the remote session now. Please open up the following link:

https://www.fastsupport.com/158999184
Follow the on-screen prompts to open/run the remote file, and click Yes when prompted to allow the remote connection. We will then be connected.

Customer: replied 2 months ago.
with remote, you don't control my computer, right?
Expert:  Bryan replied 2 months ago.

I'll be able to walk through the steps at your screen via the remote session, and we will be able to chat during the process as well. Should we proceed now?

Customer: replied 2 months ago.
it won't open
Customer: replied 2 months ago.
I have a Snow Leopard 10.6.8
Expert:  Bryan replied 2 months ago.

Please try this link again:

https://www.fastsupport.com/158999184

Do you get any error when trying to download/open the remote file?

Customer: replied 2 months ago.
GotoAssist won't open !!
Customer: replied 2 months ago.
tried it several times
Expert:  Bryan replied 2 months ago.

OK. Let me open up your question to our other experts who will be able to assist further; you will be automatically notified by email when another expert picks this up. Thank you.

Customer: replied 2 months ago.
OK
Expert:  Ashik replied 2 months ago.

Hi and Welcome. My Name is ***** ***** I look forward to assisting you today with your question.

Mac OS X 10.6.8 is about 8 years old and very outdated. No new applications will work on it, however we can install an older version of Skype but that is not a real solution. May I ask, why don't you upgrade the Mac ? Would you like to upgrade to latest version of OS X ?

Expert:  Ashik replied 2 months ago.

Remember, Skype has updated their system requirement to Mac OS X 10.9 or later. That means Skype may no longer work with older version.

If you just wanted older version of Skype, then you can download and install it from here --> http://www.oldapps.com/mac/skype.php?old_skype=13159

If that version didn't work, then try this version --> http://www.oldapps.com/mac/skype.php?old_skype=11978

If you would like to upgrade the OS X to latest possible version, please let me know and I will send instructions for that

Customer: replied 2 months ago.
Hi, Ashik -- I will get back to you later about this! Thanks so much for all your help.
Expert:  Ashik replied 2 months ago.

You're most welcome !

Expert:  Ashik replied 2 months ago.

Hi there, It's me Ashik again. How is it going ?