How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Jins M. N. Your Own Question
Jins M. N.
Jins M. N., Computer Hardware Engineer
Category: Mac
Satisfied Customers: 2549
Experience:  Mac Expert, 7+ years of experience in installation and trouble shooting of mac osx and apps
Type Your Mac Question Here...
Jins M. N. is online now
A new question is answered every 9 seconds

Hi Mike, I found an earlier discussing that was not completed

Customer Question

Hi Mike,

I found an earlier discussing that was not completed in which you are trying til help find and open the iWeb/domain.sites2 file for some one.

I har that problem now and it is killing me. I here is the complete error message that pops up when ever i click the iweb icon.:
can not open the arkive: library/application support/iweb/domain.sites2

Can you help me.

I had run out of space on my HD so I had been putting things in the trash can however i an 100% sure i did not toutch the Iweb stuff as it i hidding i mountain lion and did not find out of that before after.... the problem had accured.

I am running os x 10.8.4
processor 3.06ghz intel core i3
Submitted: 4 years ago.
Category: Mac
Expert:  Jins M. N. replied 4 years ago.
Hi, Thanks a lot for posting your query here. Mike is offline now and I am Jins here to assist you.

Did you performed any mac upgrade ? Anyway Try the following:

1 - move the domain file to the Desktop.
2 - launch iWeb, create a new test site and save. Quit iWeb.
3 - move the new domain file to the trash. Move the old domain file back to the original location.
4 - go to your User/Library/Caches folder and delete the iWeb folder.
5 - reboot.
6 - launch iWeb;

See if that will let you open the original domain.sites2 file.


Customer: replied 4 years ago.

Hi Jins,


Done that now and the same message comes up. Iweb open perfektly after moving my old domain.sites2 file out..


but after moving it back and deleting caches it came up with the same error

Expert:  Jins M. N. replied 4 years ago.
Okay, then please try the following.

Try the following:

  1. delete the iWeb and preference files, and, that resides in your Home/Library/Preferences folder.
  2. launch iWeb and try again.




Customer: replied 4 years ago.

deleted the file but could not find the file in there.

Still the same error

Expert:  Jins M. N. replied 4 years ago.
Okay, then please give read and write access to user everyone on that old domain file. Check this tutorial to see how to set file permission.

After setting permission try to launch iWeb again.

Customer: replied 4 years ago.

still the same ;-/

Expert:  Jins M. N. replied 4 years ago.
It seems, the domain file is corrupted. Please try the following.

Quit iWeb

In the Finder, right click the corrupted domain file
-> Show Package Contents
-> find all the .plist files (3 mostly) then drag and drop them to desktop
Then open this domain file with iWeb.
If it works, you will have to publish the entire site again.


Expert:  Jins M. N. replied 4 years ago.
If it also do not helps, the only thing you can try is running Disk Utility to repair permissions. Disk Utility is in Finder/Go/Utilities. If repair permission also do not helps, try safeboot your mac. Then check iweb from there. If it also do not helps, there is sad news for you. You can't deal with that domain file any more.

iWeb stores all your website data in the file domain.sites2. If you lose your domain file or it gets corrupted you’ve lost your site. Remember you can export your website files to a folder but you CANNOT import them back into iWeb.



Please remember these things when we deal with your issue. It may take more than one step/answer to solve a problem. So If my answers don’t work or if you are not satisfied, please don’t Rate my answer as Bad or Poor Service, but please Reply back to me by clicking the “Continue Conversation” or “Reply” button and I will gladly continue to help. Remember, only Rate answer after you are 100% Satisfied. Please do not rate an answer, if you are not satisfied.

Customer: replied 4 years ago.

cant find the Utility for repair.

Expert:  Mike replied 4 years ago.
You can do it this way:

Restart the computer while holding the Command and R keys to boot to Recovery HD partition, when it boots select the Disk Utility and Continue. Then select Macintosh HD on the left and first Verify Disk on the right and if that is OK Repair Permissions. If Verify Disk is not OK try to Repair Disk.
Expert:  Jins M. N. replied 4 years ago.
Please check this detailed tutorial.


Related Mac Questions