How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask David Your Own Question
David
David, Mac Support Specialist
Category: Mac
Satisfied Customers: 1495
Experience:  BSc H.Dip Apple Certified Professional
39216975
Type Your Mac Question Here...
David is online now
A new question is answered every 9 seconds

I have a late 2011 Macbook Pro 13”. When its plugged into a

Customer Question

I have a late 2011 Macbook Pro 13”. When its plugged into a power source it runs fine. When running on battery however, it runs extremely slow (Lagging mouse movement, slow to load programs). Although it shows 90% or more
battery power. The little spinning ball is usually running on almost every key stroke.
Do I need to buy a new battery, it is almost two years old?

Thanks
Tom Collier
Submitted: 4 years ago.
Category: Mac
Expert:  David replied 4 years ago.
Hi Tom, my name is David, and I will do whatever I possibly can to help answer your questions.

This sounds like an unusual issue. Did you erase the disk and only install Mac OS X and nothing else when you were troubleshooting?

Sincerely,
David.
Customer: replied 4 years ago.

Yes, I erased down to factory and installed Mountain lIon. LIke I said all works well when on the power cord. Without the power cord, even typing is slow. I have to wait for the letters to appear sometimes 1-3 seconds. Makes typing a pain.


 


 


Tom

Expert:  David replied 4 years ago.
Hi,

Are you sure you did not do a reinstall of Mac OS X and actually erased Macintosh HD then installed?

Was there none of your applications or data on it after?

Did you recover from a backup after erasing and before testing?

Sincerely,
David.
Customer: replied 4 years ago.

I used the recovery disk on the factory page as directed. Not the HD.


After reinstalling MLion, everything worded fine until I tried to run on battery.


Just for your information, I have a 27" IMac, and iPad, and I Phone and and old 13" MacBook that still runs fine.


 


Tom


 

Expert:  David replied 4 years ago.
Hi Tom,

What I'm trying to find out is if you did a Recovery, or actually wiped the HD before the Recovery.

As you can see in this article, the steps require you to use Disk Utility first before Recovery:
http://support.apple.com/kb/PH11273

Can you confirm that this is what you did, and not just a Recovery?

Sincerely,
David.
Customer: replied 4 years ago.

I did use disc utility before recovery. Not sure I can give you very technical answers, as I can only do what the computer ask. The main reason I like Apple is it walks you through almost everything.


I am about 11/2 hours drive from an Apple store, but perhaps I will need to go there.


I do appreciate your help


 


Tom

Expert:  David replied 4 years ago.
Hi Tom,

You shouldn't worry about the technical answers, too technical anyway. When you said factory, there is often the mistake of thinking a Recovery does that. Recovery will leave some problems still on the Mac.

If you used disk utility, and erased, as it is in the article I linked, then I will take it that you have.

This rules out a lot of things that can be done, anything to do with software on Macintosh HD. That has been ruled out as a cause.

Do you have a USB mouse? I am curious to see if the behavior is the same. It will help with troubleshooting.

Sincerely,
David.
Customer: replied 4 years ago.

To answer a former question. Yes all data and apps were erased.


No mouse, using the track pad.


 


Tom

Expert:  David replied 4 years ago.
Hi,

That means you have been very thorough. the only troubleshooting would seem to be the SMC reset.

Please scroll down to the section for Mac's with a battery you should not remove, and carry out the 5 steps. Here:
http://support.apple.com/kb/ht3964

Let me know how that goes.

Yours sincerely,
David.
Expert:  David replied 4 years ago.
Hi,

Did you reset the SMC a few times, and did it make any did it make any difference?

Please let me know thank you.

Yours sincerely,
David.