How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ashik Your Own Question
Ashik, Mac Technician
Category: Mac
Satisfied Customers: 10839
Experience:  Bachelor of Computer Application (BCA), 9+ Years of Experience in troubleshooting Macs, iPhone, iPad, iPod etc
Type Your Mac Question Here...
Ashik is online now
A new question is answered every 9 seconds

my space bar has stopped working. I have changed the key board

Customer Question

my space bar has stopped working. I have changed the key board to a new keyboard but still the space bar does not work. I have thrown away the keyboard preference folder and restarted - but still have the problem - Help !! I have os x 10.5.8
Submitted: 5 years ago.
Category: Mac
Expert:  Ashik replied 5 years ago.
Hi My name isXXXXX hope i can help you.

We can try some basic troubleshooting steps and see if that works or not.

Reset PRAM and NVRAM (Solution 1)
  1. Shut down your Mac
  2. Locate the following keys on the keyboard: Command, Option, P, and R.
  3. Turn on the computer.
  4. Press and hold the Command-Option-P-R keys. You must press this key combination before the gray screen appears and before the chime sound.
  5. Hold the keys down until the computer restarts and you hear the startup sound for three times.
  6. Release the keys.

Restart in Safe mode
(Solution 2)
Make sure that the computer is shut down. Press the power button. Immediately after you hear the startup tone, press and hold the Shift key. Release the Shift key when you see the gray Apple and progress indicator. Let the Mac boot up...

Run Disk Utility in Single User Mode(Solution 3)
Turn your Mac off. Turn it back on and this time hold down the Command (Apple) key and the S keys at the same time. Then type the following command...

/sbin/fsck -fy (note the space between fsck and -fy)

If you can't run /sbin/fsck - fy then type only fsk - fy

Hit return and the disk utility should run and let it finish. When it finishes and there is no error, then type reboot and hit return. Let the Mac boot up. (Disk Utility will fix all system errors, bad preferences files etc)

Let me know if that didn't worked. Only click Accept after it worked.
Customer: replied 5 years ago.
I tried no. i solution - did not work.
I tried no. 2 solution - did not work
On no. 3 solution - I can get the disk utility up and running - but ALAS what you are asking me to type - in each case - needs me to type a space - AND I CANNOT DO THAT...

so where as I am sure that being able to run the disk utility is a very good idea - and which I hope once it repares all the preferences etc etc. we should be somewhere I cannot follow your instruction for solution number 3 as written. so now what do I do?

by the way, I appreciate all your help =- My recommendation is please don't assume that people know a Mac keyboard - I am helping my 90 year old mother! and I am not a mac person - so I did not know what Command and Option keys are on a Mac - I had to go look that up in Wikipedia.... otherwise.. I thank you and am very anxious to await your next feedback -Christine
Expert:  Ashik replied 5 years ago.
If you can't use Space on disk utility, then it means its just not a software problem. Do you have the Mac OS X installation discs ?

Command key is the Apple key and option key is the alt key.
Customer: replied 5 years ago.
HI I may have them but not with me where I have the computer - its' a G5 machine and I don'thave the original discs.. but I do have I think a set of start up discs at another location....I will need to take my car to go get them -- Can I come back to you in something like a couple of hours ? I am in France. what are you thinking I will need to do next?

also I don't understand why I should be able to type the space into the commmand area - since I can't type a space atall -- so why would you expect the space bar to suddenly start working? I am sure if I could run the disk utility we might get some where - and the only reason why I can't is because I cant type the space between fsck -fy
thanks for letting me know what to do next once I hvae the discs
Customer: replied 5 years ago.
Also PLEASE tell me how to exit the black screen
I am at root# XXXXX says if i wish to boot the system

exit but I do NOT know how to exit!
thanks for letting me know
Customer: replied 5 years ago.
How do I get out of the boot system area - it says exit but does NOT tell me
what to do to exit so i can get back to the regular log in area
Expert:  Ashik replied 5 years ago.
We need the discs to troubleshoot further. I thought the problem is with Mac OS X, but its not. The Space will work in Single User Mode if its just a software issue. I think this is a firmware problem. That is why it is not working in Single user mode or in Mac OS X.

When you get the discs, You can do a Archive and Install. Archive and Install will not remove any of your files,applications, settings etc. It just replaces the system files with new one.

Archive and Install : Read Instructions

To get out Single User Mode, type reboot and hit return key.

Let me know if that didn't worked.
Customer: replied 5 years ago.
I have not yet been able to find my discs - as soon as I have found them - later this evening, I will be able to try the additional advice you have given. as soon as I have done that I will let you konw what happened - but it will be tomorrow morning... as my sister is not back till this evening adn I have no way to contact her till she gets back.
thank you for your patience in the meantime.. I am most anxious to resolve this.
thank you again Christine
Expert:  Ashik replied 5 years ago.
You're welcome Christine. But i'm not very confident this will work, because if this is a firmware issue you're gonna have to take it to the Apple Store.
Ashik and 2 other Mac Specialists are ready to help you
Customer: replied 5 years ago.
HI there, oh dear! that's really too bad -- -I will let you know when I\ve been able to try....alas my mother's only sister died suddenly yesterday - so it\s going to be another day or so before I can work on this - but I promise I will try to do what you are suggesting and I will let you know the outcome.
best christine
Expert:  Ashik replied 5 years ago.
I'm sorry about that....Okay. Let me know if that didn't worked. Add a bookmark of this page, so you can get back to me later.

Take Care,
Customer: replied 5 years ago.
ok I will do that thanks -
I'll be back to you as soon as I can
Expert:  Ashik replied 5 years ago.
Great !
Customer: replied 5 years ago.
alas I could not do anything with the start up disc - the one I have is Mac os X snow leopard whcih can only be used on the G5 computer if it's running os X 10.6 and up - and it's only running 10.58 no other discs are available.

I did run disk utility and checked the disc and the permissions - both of which checked out ok...
so I am sorry I will indeed have to take the computer in to have the firmware issue resolved...
Expert:  Ashik replied 5 years ago.
Hi, We need the discs to troubleshoot further. Since you don't have them, you have to take your Mac to the Apple Store. I'm sorry i couldn't solve your problem..

Best Regards,