How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Toyota Service Your Own Question
Toyota Service
Toyota Service, Lexus and Toyota expert
Category: Lexus
Satisfied Customers: 4950
Experience:  30 + years of experience; Multiple Award Winning Svc Mgr; Just Answer Customer's Choice Award Winner
14892859
Type Your Lexus Question Here...
Toyota Service is online now
A new question is answered every 9 seconds

I have a 2007 is250...having a headlight issue, I have

This answer was rated:

Greetings, my name is ***** ***** I have a 2007 is250...having a headlight issue, I have replaced both HID low beam bulbs and yet lights still wont come on! I don't have a lot of money to diagnose exactly what is wrong. I saw something about the headlight relay perhaps being bad, could replacing that perhaps end this mystery? Much thanks, *****: Have you checked the fuses? Have you checked the bulbs?
Customer: Hi Pearl, yes have checked fuses and just replaced the bulbs.
JA: What is the model of your '07 Lexus?
Customer: IS250
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: working on it with a friend that is a mechanic, we replaced the bulbs so far, wondering if it could be the headlight relay
JA: Anything else you want the mechanic to know before I connect you?
Customer: no, I think that should be it, thank you!

Hello. Welcome to Just Answer. Please allow me to assist you. I would doubt highly that the relay is the issue. Please describe the issue that was occurring that caused you to replace the bulbs. Did they illuminate then go back out after a few seconds?

Toyota Service and other Lexus Specialists are ready to help you
Customer: replied 1 month ago.
Well it's a 2007, I have had the car for roughly 2-1/2 years so I attribute the bulbs going out just to age of the vehicle. When the bulbs were replaced, they never came on at all...still nothing when I activate the lights.

Check for power in the H-LP R/LWR and the H-LP L/LWR. If you have power in these fuses the relay is OK. Check for power at the ballast in the Red with a Black stripe wire (Driver side) and power to the Red with a Green stripe wire (passenger side). If you have power in both wires I suspect faulty ballasts. Thanks for choosing Just Answer.