How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Kia
Satisfied Customers: 23110
Experience:  ASE Master and Advanced level certified. Factory trained with 17 years dealership experience
9825021
Type Your Kia Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a amantti 2004 the won't start the radio clock

Customer Question

i have a amantti 2004 the won't start the radio clock display will say no con
JA: Will the headlights turn on? Is the battery fully charged?
Customer: yes
JA: What is the model of your '04 Kia?
Customer: amanti i was told to disconnect battery to reset computer when i do this it starts a couple of times and then the trouble starts all over
JA: Are you fixing your Amanti yourself? What have you tried so far?
Customer: i just told you yes tryng to fix myself
JA: Anything else you want the mechanic to know before I connect you?
Customer: nope
Submitted: 12 months ago.
Category: Kia
Expert:  Chad Farhat replied 12 months ago.

Hi, I'm Chad. Welcome to JustAnswer. I'm reviewing your question and I will be posting your reply ASAP.

Expert:  Chad Farhat replied 12 months ago.

hey how are you

since you done the disconnection and it came back that means we have an issue obviously in the ECM, antitheft module ,alarm switches

wiring etc..

you will need a factory scanner or equivalent to run a diagnostic scan & retrieve fault codes from all modules so we can narrow it down.

did you inspect the wiring harness connector to the ECM fro backed out pins or burned out spots making poor connection

Try spray Electrical Contact cleaner ,

if you get it scanned and retrieve fault codes let me know

Please let me know

Thank You

Chad Farhat

ASE Certified Technician

Customer: replied 12 months ago.
I checked it out and it started but when i tried it later on it wouldn't start. i get no con on the display been told it's a problem with radio need to disconnect the radio fuses Can you tell which fuses they are there is 1 under the hood and two inside.
Customer: replied 12 months ago.
no thank you
Expert:  Chad Farhat replied 12 months ago.

thank you, you welcome

Expert:  sprinkles08 replied 12 months ago.

Hello and welcome to JustAnswer!

The fuses that power the radio are the 30a IGN SW-2, 30a P/FUSE-1, and the 15a AV/CLOCK fuses.