How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Kiatech Your Own Question
Kiatech
Kiatech, Kia Master Technician
Category: Kia
Satisfied Customers: 210
Experience:  30+ years experience,ASE certified,KIA certified Master Technician,Ford factory trained
32162675
Type Your Kia Question Here...
Kiatech is online now
A new question is answered every 9 seconds

I have a 04 Spectra 2.0 thats stalls ,heistates at time if

Customer Question

hello i have a 04 Spectra 2.0 thats stalls ,heistates at time if it sits after driving it sometimes is hard to restart.... we have cleaned throttle body and did relearn ..replaced IAC.etc.no help.. the only code it has is P0449..any ideas .thanks...
Submitted: 1 year ago.
Category: Kia
Expert:  david craig replied 1 year ago.

Hi Im David, thanks for visiting the site, let me look up some info on your car, thanks

Customer: replied 1 year ago.
thanks
Expert:  david craig replied 1 year ago.

lets start by checking the pcv valve and hoses for restictions.

Customer: replied 1 year ago.
checked those they are fine ..no cracks etc
Customer: replied 1 year ago.
when it does run and idle it sounds great..it will once in a great while stutter and catch itself.. then others just quit and then its hard to restart.start die start die unless i rev hell out of for a few seconds
Expert:  david craig replied 1 year ago.

ok. do you have a scan tool that can read live data?

Customer: replied 1 year ago.
Expert:  david craig replied 1 year ago.

will the car start today?

Customer: replied 1 year ago.
it will probably start and run fine right now..it ran fine for a few days then i put fuel in it and then this issue started all over again..and only code is p0449..
Expert:  david craig replied 1 year ago.

ok, start it up with the scan tool installed. watch the o2 sensors and tell me what they are doing in closed loop.

Customer: replied 1 year ago.
you want up and downstream or just upstream
Expert:  david craig replied 1 year ago.

both

Customer: replied 1 year ago.
sorry for delay its storming here right now.. Can the code p0449 for the CCV valve cause this issue as tank is not venting?
Expert:  david craig replied 1 year ago.

nope. sorry.

Expert:  david craig replied 1 year ago.

p0449 wont cause driveability issues

Customer: replied 1 year ago.
darn been storming all day haven t been able to scan yet....have you seen this issue before on this car before ?...from before today...O2 show no sign of running lean..there where no misfires...i was kinda thinking with Evap vent stuck closed perhaps canister was being overwhelmed and engine was overwhelmed with gas fumes or raw fuel..thru vapor system
Expert:  david craig replied 1 year ago.

have never seen that happen

Customer: replied 1 year ago.
ok got to scan just now.. upstream is around 1800 to 2100 millivolts..rear is around 400-600 millivolts
Expert:  david craig replied 1 year ago.

rear is excellent. the upstrams should fluctuate between .1-.9 volts

Customer: replied 1 year ago.
ok so front is reading to high or extremely rich?
Expert:  david craig replied 1 year ago.

like there totally open. like not connected almost

Expert:  david craig replied 1 year ago.

is that 1.8 - 2.1 volts? or millivolts?

Expert:  david craig replied 1 year ago.

nevermind... it adds up the same. so yes, there open

Expert:  david craig replied 1 year ago.

checking in to see how its going