How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask KALAMYKID Your Own Question
KALAMYKID
KALAMYKID, shop owner/tech
Category: Kia
Satisfied Customers: 4026
Experience:  I HAVE OWNED MY OWN SHOP FOR OVER THREE YEARS. I HAVE THE TOOLS AND SOFTWARE TO ANSWERE ALMOST ANY Question
5629372
Type Your Kia Question Here...
KALAMYKID is online now
A new question is answered every 9 seconds

I have a 2001 sportage has fuel and injector pulse but no

Customer Question

Hi i have a 2001 sportage has fuel and injector pulse but no spark , the car got caught in flood waters ! the ecu got wet and i put a new ecu in . when the car got wet the fuel pump was running continuously . car has dried out but still cant get spark ??
JA: Have you ever replaced the fuel pump, or is this the original?
Customer: it is the original . it is working fine . the taco is not showing any revs could this be a crank or cam sensor ?
JA: Are you fixing your Sportage yourself? What have you tried so far?
Customer: have dried the electrics changed the ecu . checked to make sure there is fuel pressure and injector pulse all that is ok
JA: Anything else you want the mechanic to know before I connect you?
Customer: reckon thats about it
Submitted: 10 months ago.
Category: Kia
Expert:  KALAMYKID replied 10 months ago.

Do you have 12 volts to the white wire with a red strip to each of the two coils?

Customer: replied 10 months ago.
have not checked that yet
Expert:  KALAMYKID replied 10 months ago.

See if you do. If you have injector pulse, then the pcm is getting the correct info from the cam and crank sensors.

Customer: replied 10 months ago.
cheers ***** ***** to see if theres power
Expert:  KALAMYKID replied 10 months ago.

If you have a noid light that will fit the coil plug, you can use it to see if you have power as well as a ground pulse from the pcm.

Customer: replied 10 months ago.
have almost 12 volts at the coil wiring ! does this meen the coils are fried ?
Expert:  KALAMYKID replied 10 months ago.

Do you have a noid light?

Customer: replied 10 months ago.
have mood light plugged it in and got no light ?!
Expert:  KALAMYKID replied 10 months ago.

Then we will need to test at the ecu and see if it is sending a signal out to the coils. Did you use a noid light to check the plugs with both coils unplugged?

Customer: replied 10 months ago.
used a noid light to check with both coils unplugged , was thinking o trying some 2nd hand coils but am thinking the problem is further in !!
Expert:  KALAMYKID replied 10 months ago.

Do you have a test light with a regular bulb in it? If so connect the test lead to the positive post of the battery and then test the negative wires at each coil with some one turning the engine over, see if you get a pulsing light on the test light.

Customer: replied 10 months ago.
Will try that tomorrow , Knocking off for the night . Thanks for your help .
Expert:  KALAMYKID replied 10 months ago.

You are very welcome. Chat with you tomorrow.