How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT
EricFromCT, Technician
Category: Kia
Satisfied Customers: 3959
Experience:  Kia Professional Elite, ASE A1-A9 L1 L2 Certified. 20 years dealer experience.
34559540
Type Your Kia Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

I have a second hand 1999 Auto Sportage 2.0 4X4, went

Customer Question

Hi there, I have a second hand 1999 Auto Sportage 2.0 4X4, went through some water in a pot hole today, lost power and dials all went dead. When I turned it off, it would not start again, just cranked away. I turns out the 10 A "meter" fuse was blown, replaced it and it was fine for a short while. Same thing re-occurred, got another fuse and the same thing happened again... I am in Malaysia, so finding a mechanic that speaks English is quite difficult. Is it possible to sort this myself?
Submitted: 2 years ago.
Category: Kia
Expert:  EricFromCT replied 2 years ago.

Hi. If the 10amp meter fuse keeps blowing then there is a short to ground. The meter fuse sends power to the vehicle speed sensor, the transmission control module, the transmission range switch and the rear hatch release switch. You may be able to sort this out yourself but you will need to find the shorted wires.

Expert:  EricFromCT replied 2 years ago.

Since it seems to blow over bumps, check the easiest places to look first. Check the wiring harness to the speed sensor and the trans range sensor, for and signs of the harness shorting or rubbing on something.

Expert:  EricFromCT replied 2 years ago.

The wire in question should be a green/red wire. Do a visual inspection, and possible wiggle the harness to while looking for the short, and then let me know if you find anything. Thanks.

Customer: replied 2 years ago.
Thanks for this feedback, could you indicate where to look for this wire? is it in the engine bay or on the chassis?
Expert:  EricFromCT replied 2 years ago.

The wire is in the engine bay. The speed sensor is on the transmission. and the range sensor is on the transmission as well. It has the linkage from the shifter inside the car attached to it. The harness and wire in question will be in that general area. Thank you.