How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Kia
Satisfied Customers: 24207
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Kia Question Here...
Dan is online now
A new question is answered every 9 seconds

Kia sportage: 2000 kia sportage flashing hold light, check

Resolved Question:

2000 kia sportage flashing hold light, check engine came on and stays on. tranny shifts fine in 1,2,3 but wil not go into 4th or (overdrive)
Submitted: 5 years ago.
Category: Kia
Expert:  Dan replied 5 years ago.
Welcome to JustAnswer, my name is XXXXX XXXXX I'm here to help get your problem resolved. Ask follow up questions, thanks. Coolant temp sensor is common to fail causing this to happen, then it will not go into overdrive because computer doesnt know correct temp and doesnt shift into overdrive until it knows vehicle is warm..I would start by having diagnostic codes checked which you can have done at your local parts store for free. With codes they might be able to tell you the problem if not you can write them down and reply to this answer at any time even after you accept without any additional fee's. Let me know if you have questions, thanks.
Customer: replied 5 years ago.
Where is the location of the coolant temp sensor and is it easy to replace?
Expert:  Dan replied 5 years ago.
Here are replacement instructions but make sure to have diagnostic codes checked to verify codes are related before replacing. Let me know if you have questions, thanks.

http://db.tt/jvcZu7Vb
Customer: replied 5 years ago.
Codes p1795 & p1624
Expert:  Dan replied 5 years ago.
This usually means the 4x4 selector switch has failed, here are testing instructions. Let me know if you run into questions, you can reply at any time even after you accept without any additonal fee's. Thanks.

http://db.tt/7JHuus0
Dan and 2 other Kia Specialists are ready to help you
Customer: replied 5 years ago.
I did not do the 4x4 selector switch at this point. i got thinking about this a little more in depth, About a week ago I used theXXXXXa short time and then turned it off a couple days later. That's when I got the problems. Thinking about what you said made sense about the switch and decided to try theXXXXXagain instead of getting underneath the vehicle at this point. I put it in 4 low and then took it back out and put it back in 2 wheel. I started to drive it again and it shifted in overdrive just fine. I then reset the codes to clear out everything and all is well at this point and no lights are coming back on. I believe it is possible that since I have not used the 4 x 4 in ages, this could have been the culprit. All is fine at this point after driving it 50 plus miles today, but I will keep you posted if something rears its ugly head again. Thanks for the collaboration. Merry Christmas and thanks for the help.
Expert:  Dan replied 5 years ago.
Good to hear its working, keep me posted and let me know if you run into questions. Thanks.