How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Jeep
Satisfied Customers: 29084
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Jeep Question Here...
Pete is online now
A new question is answered every 9 seconds

1999 jeep 4.0 running very rough. The jeep overheated two

Customer Question

1999 jeep 4.0 running very rough. The jeep overheated two weeks ago and had to replace water pump and radiator. I also replace #6 injector due to check engine light. That spark plug is very black in color. help
Submitted: 1 month ago.
Category: Jeep
Expert:  Pete replied 1 month ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

Is the spark plug worn at all and was it replaced as well?

Let me know so we can continue,thanks Pete

Customer: replied 1 month ago.
I replaced all spark plugs
Customer: replied 1 month ago.
e-mail
Expert:  Pete replied 1 month ago.

O.k.,if the new spark plug is becoming black it is being over fueled by the injector and since the injector was already replaced what usually happens is a faulty injector can be installed that causes to much fuel to enter a cylinder and causes this issue here.I have installed several injectors in the past and have had some that over fuel the cylinder and causes this issue needing replaced again.

I would check and make sure the wiring to the injector is o.k.If the wiring is found to be o.k. then I would test to see if you have a solid power signal on one wire at the injector with the key on or engine running.Then check the other wire to see if it has a pulsed off/on ground with the engine running.If it has a solid ground this indicates either the wire is shorted to ground leading to the computer or the computer has an internal fault needing replaced if all wiring is found o.k.

If you have both the solid power and pulsing off/on ground signal then this indicates the new injector you installed is faulty and needs replaced again under parts warranty from the facility you had purchased it from.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated ( should be a link to click on here or above).You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete