How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 23100
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
9825021
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

I have a 2011 Jeep Compass. When I turn the key to the

Customer Question

I have a 2011 Jeep Compass. When I turn the key to the ON/Run position none of the warning indication lights come on. When I start the engine they do show briefly.
JA: Is the car in "Park" or "Neutral?" Do you know if your car has a "wheel lock" feature?
Customer: The care is in part and the steering wheel is locked in position.
JA: Are you fixing your Compass yourself? What have you tried so far?
Customer: I have not tried anything so far. Will take to mechanic if needed.
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 5 months ago.
Category: Jeep
Expert:  sprinkles08 replied 5 months ago.

Hello and welcome to JustAnswer!

It sounds as if you may have an internal failure in the instrument cluster. I'm assuming that the cluster doesn't work other than the brief time when warning lights come on. If that's the case then it is either losing a power or ground feed or there is an internal failure.

Does the instrument cluster not work while driving?

Customer: replied 5 months ago.
Instrument cluster works fine while driving. I plugged in my scan tool and no codes are stored. MIL status is off. All other monitors are n/a except comp component which is ok.
Expert:  sprinkles08 replied 5 months ago.

So with the key turned to the run position the instrument cluster doesn't work, but if you start the engine and return the key to the run position it then works?

Customer: replied 5 months ago.
Expert:  sprinkles08 replied 5 months ago.

If that's the case then fault codes are going to be set for lack of communication with the instrument cluster. Is it actually a generic code reader that you're using?