How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: Jeep
Satisfied Customers: 22648
Experience:  Chrysler/Dodge/Jeep Master Certified, ASE Master and Advanced Certified, Trans and Hybrid Specialist
9825021
Type Your Jeep Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

It turns lights on when parked and no ignition key in...

Customer Question

Hi! It turns lights on when parked and no ignition key in... Wrangler TJ 4.0, 2000
JA: Is the car in "Park" or "Neutral?" Do you know if your car has a "wheel lock" feature?
Customer: Manual. In gear, handbrake pulled. I assume some quirky electrical struff. It does ru, sometimes does not stop when turned off. We have checked ground and it is OK
JA: What year is your Wrangler?
Customer: 2000 YOM 1999, model 2000, european edition
JA: Are you fixing your Wrangler yourself? What have you tried so far?
Customer: With help of local mechanic. Not very common car in Slovenia, Europe. We have cleaned all the contacts, also ignition switch mechanism, ground terminal....
JA: Anything else you want the mechanic to know before I connect you?
Customer: I do not undertand the question..
Submitted: 5 months ago.
Category: Jeep
Expert:  sprinkles08 replied 5 months ago.

Hello and welcome to JustAnswer!

You most likely have a bad multifunction switch. If it's the headlamps or fog lamps that are coming on by themselves and there are no aftermarket electrical modifications then the multifunction switch will be the issue. It would need to be replaced, and the connector replaced along with it if there are signs of heat damage.

Customer: replied 5 months ago.
Hello,
There are no aftermarket mods to the car.
If you are referring to light switch - I honestly do not understand how that could effect the electrics in a way that I can not turn off the engine. When this happens I have to remove battery terminals to stop the engine.
The problem started a week ago. I drove it on Monday, parked it and went on a trip. Frost kicked in and on Wednesday neighbour called that I have light s on! My wife went to inspect and there was no key in the ignition (of course), all the dash lights were on, heater fan was on. She could not turn anything off, even using ignition key. In the end only removing battery terminals stopped the strange behaviour. We have recharged the battery, could start the engine, turn it off, car was normal. After a while (within the same day) - the problems reappeared.
We have cleaned ground terminals and main ignition switch...
Are you sure about the light switch?
With kid regards,Matjaž
Expert:  sprinkles08 replied 5 months ago.
Your first post stated that lights were coming on by themselves and mention anything about the engine. What specifically is happening with the engine?
Customer: replied 5 months ago.
Hi,Engine runs normaly. Only it does not turn of. In same occasion also dash lights do not turn of, despite ignition key removed... To stop the engine I have to disconect batery terminal.
Expert:  sprinkles08 replied 5 months ago.

It's unsafe to disconnect a battery with the engine running, you'd want to remove the ASD relay.

Did this and the light issue start at exactly the same time and only happen together?

Customer: replied 5 months ago.
Hi, I am not familiar with ASD relay...I did it first time, next time I just stalled the engine in first gear and then removed terminal...Yes, they do happen at the same time... So when I have problems with stopping also dash light stay on until I remove the bat. After a while, when I reconnect the bat it is OK, than after a while suddenly dash lights pop on. The car was in the mechanics garage in side corner "on observation therapy" and it did happen once or twice a day...I was looking to this - http://www.fourwheeler.com/how-to/electrical/154-1004-top-ten-jeep-electrical-problems-and-cures/
but I do not have this old style terminal block to clean - new type sealed connectors...Puzzled :-/Kind regards
Expert:  sprinkles08 replied 5 months ago.

Do you have an aftermarket remote start or alarm?

Customer: replied 5 months ago.
Just plain stock jeep. No aftermarket stuff on it. Not even light on alarm...
Expert:  sprinkles08 replied 5 months ago.
Did you buy the vehicle used?
Customer: replied 5 months ago.
But it was running fine without a problem.for months. When i bought iti replaced the battery, made a full service (all fluids, filters, brakes...)
Expert:  sprinkles08 replied 5 months ago.

Have you physically disassembled the dash to look for a remote start or alarm that you're not aware of?

Customer: replied 5 months ago.
Hi! As I wrote before - I have physically disassembled the start lock assembly to bare bones, also to inspect for corrosion, but did not find anything that would look non stock.Actually you can not start the manual shift jeep without pressing the clutch pedal - so remote start would be of no use... We live in moderate climate and remote starting is virtually unknown here. More like separate Webasto preheating can be operated remotely...
Expert:  sprinkles08 replied 5 months ago.

But have you disassembled the dash and inspected for a remote start or alarm? I'm not concerned with the lock cylinder.

Customer: replied 5 months ago.
Hi!
We have taken apart the dash. All standard...
Expert:  sprinkles08 replied 5 months ago.

You mentioned 'dash lights' coming on by themselves. Can you elaborate on that?

Customer: replied 5 months ago.
They just pop on. If any other switch was let on (for instance fan) also pops on. Just like that.As I wrote, I was not even at home when it appeared...
Expert:  sprinkles08 replied 5 months ago.

What lights are you seeing though? I need to know specifically what you're seeing as I am not there to experience the problem in person.

Customer: replied 5 months ago.
Not sure for light by light status - need to check in the morning as it is now 0:23 locally :-/
As far as I recall - there is a green light for short beam, back light for the speedo and rpm gauge, back light on the switches.
I can make a photo of it.
Expert:  sprinkles08 replied 5 months ago.

A photo would be great.

Customer: replied 5 months ago.
Hi, wanted to do it when I came home - but my neighbour - the mechanic - already took it to loxal car electrician.
I will get the photo tomorrow. We spoke again an one good wek of observation results as:
Odometer light always on
Air bag light orange almost always on
Key code light orange a bit less, but almost always on
Other lights on in random cases.. .
Today before moving it hesitated to start, stalled when accelerator was touched. Ten minutes later after left alono for a while - started like it should....
My mechanic checked at local dealership and they do remember similar case. They have replaced ECU to solved - which sound a bit dramatic to me :-/Kind regards,Matjaz
Expert:  sprinkles08 replied 5 months ago.

The PCM won't be the cause of what you're experiencing.

Customer: replied 5 months ago.
Hi!Photo in the attachment.Meanwhile we found the bug by coincident...Two cables had shielding cut by sheetmetal on the passage through firewall...Kind regrds,Matjaž
Expert:  sprinkles08 replied 5 months ago.

I'm glad you got it repaired!