How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Technician
Category: Jeep
Satisfied Customers: 28186
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Jeep Question Here...
Pete is online now
A new question is answered every 9 seconds

WELL. IT WILL START COLD BUT NOT WARM. I HAVE TO LET IT SIT

Customer Question

WELL. IT WILL START COLD BUT NOT WARM. I HAVE TO LET IT SIT FOR ABOUT 15 MINUTES BEFORE IT WILL START AGAIN
JA: Have you checked the battery, particularly the terminal connections? Are they corroded?
Customer: HAD THEM CHECKED THEY ARE GOOD AND SO IDSS THE BATTERY
JA: What is the model of your '15 Jeep?
Customer: 2006 JEEP LIBERTY LIMITED EDITION
JA: Are you fixing your Liberty yourself? What have you tried so far?
Customer: I BOUGHT THIS CAR BACK TEN MONTHS AGO. I NOTHICED IT HESITATING TO START FOR MONTHS THEN IT STARTED TO DO THIS WITH IT NOT WANTING TO START WARM. I TOOK IT TO A JEEP DEALERSHIP AND COULD FIND NOTHING WRONG SO THEY CHARGED ME 2OO TO REPLACE SOARK PLUGS THEN I HAD A FRIEND PUT IT ON A TESTER AND REPLACED TWO COILS. I THEN REPLACED THE GAS CAP BC OF VAPOR LOCKED THAT SEEMED TO WORK FOR MONTHS NOW ITS DOING IT AGAIN
JA: Anything else you want the mechanic to know before I connect you?
Customer: NO
Submitted: 10 months ago.
Category: Jeep
Expert:  Pete replied 10 months ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

One very common component that will cause this issue here that I have seen and had to replace several times before in the past is the crank position sensor itself.This sensor is located above the engine oil pan as shown below.The cost is usually around $100 for this sensor and less then an hour to replace.The sensor will heat up with the engine temp and cause a no start until the engine has sat and cooled a bit anywhere from 1 minute to an hour or more (in this case about 15 minutes).

I suspect with what you have described here this sensor needs replaced.

https://www.dropbox.com/s/voleizbgndlzawh/cr-10-18.gif?dl=0

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service,your 5 star rating is appreciated.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 10 months ago.
I have ordered the part and I wont know until I get it put on
Expert:  Pete replied 10 months ago.

O.k.,let me know how this turns out here when your ready and if we need to we can continue from here.

Thanks Pete

Customer: replied 9 months ago.
HI PETE, I TRIED THE SENSOR LIKE YOU SAID AND ITS STILL DOING IT. NOT HAVING THE TIME TO KEEP MESSING WITH IT, ITS IN THE SHOP. THANKS FOR TRYING
Expert:  Pete replied 9 months ago.

O.k.,I was hoping it would repair this issue due to the common fault with it.If there is anything else I can help with here let me know as I strive to achieve a 5 star rating.

Thanks Pete