How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Brad Your Own Question
Brad
Brad, Jeep Dealership Tech
Category: Jeep
Satisfied Customers: 7946
Experience:  19 Yrs Chrysler/Dodge/Jeep. ASE Master (L-1) Certified
10114124
Type Your Jeep Question Here...
Brad is online now
A new question is answered every 9 seconds

Battery completely died from not driving 6 months? New

Customer Question

battery completely died from not driving 6 months? New battery, now cranks but will not start. Tried starter spray, no change. Never had any problem before this. What should I do?
Thanks, ***** *****
Submitted: 1 year ago.
Category: Jeep
Expert:  Brad replied 1 year ago.

Good morning and welcome to JustAnswer!!!!

If you tried starting fluid and it wouldn't start then you likely have no spark.. Do you see a red light on in the dash? What codes are in the PCM?

Customer: replied 1 year ago.
No red light and I don't have a PCM.
Expert:  Brad replied 1 year ago.

Well no red light means that it's not a security issue, and yes you do have a PCM which is the Powertrain Control Module.. You will need a scantool to retrieve the codes so we can see why it's not starting.. Also I would need you to verify it doesn't have any spark..

Keep me posted,

Brad

Customer: replied 1 year ago.
What PCM scanner do you recommend for me to buy? I want one that will work on many makes
Expert:  Brad replied 1 year ago.

The one that I use at the dealership on your type vehicle is the DRBIII.. It can perform the module scan which will help in determining which ones are dead on the BUS. When you find the dead modules test for 12v and ground and if good replace the module.. You can also turn the key on and see if your TPS, MAP, CRANK and CAM sensors have 5v and if not then start disconnecting the sensors until the 5v comes back and then replace that sensor..

Glad I could help and thank you for the positive rating,

Brad

Expert:  Brad replied 1 year ago.

Thank you for the positive rating,

Brad