How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Jeep
Satisfied Customers: 3348
Experience:  Jeep Certified Master Tech
12365498
Type Your Jeep Question Here...
Chris is online now
A new question is answered every 9 seconds

Liberty: I have a 2006 jeep liberty that i just put an engine

Customer Question

I have a 2006 jeep liberty that i just put an engine in. when i first tried to start it cranks good but has no fire. checked crank sensor, double checked all wires but it wont start even tried starting fluid. Im` getting a U1120 code.
Submitted: 2 years ago.
Category: Jeep
Expert:  Mark replied 2 years ago.
Welcome to Just Answer Jeep my name is Mark.
What year is the "new" engine you installed?
Customer: replied 2 years ago.
it came from a 2006
Customer: replied 2 years ago.
the vehicle has been setting for 3 years
Expert:  Mark replied 2 years ago.
Ok, you'll need to do some basic checks. First you need to see if you have fuel pressure. Next you'll need to see if you are getting spark. One of those, or both is likely missing. Can you check those and let me know the result? Also, be sure and check each and every fuse in case there is one that is blown. Let me know....
Customer: replied 1 year ago.
it has no spark but has good fuel pressure.
Customer: replied 1 year ago.
I thought I had it fixed yesterday because it tried to fire a couple of times. I thought it was out of gas, but I put about 8 gallons in it today and it tried to fire a couple of times again, but now its not firing again.