How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris Your Own Question
Chris
Chris, Shop Foreman
Category: Jeep
Satisfied Customers: 3692
Experience:  Jeep Certified Master Tech
12365498
Type Your Jeep Question Here...
Chris is online now
A new question is answered every 9 seconds

2002 jeep cherokee: stopped running..tryed..crank sensor..cam sensor

Customer Question

2002 jeep cherokee stopped running has code p0320 and p0340 tryed crank sensor still not running maybe cam sensor??
Submitted: 8 years ago.
Category: Jeep
Expert:  sprinkles08 replied 8 years ago.

Hello and welcome to JustAnswer!

 

Which engine do you have?

Customer: replied 8 years ago.
4.0
Expert:  sprinkles08 replied 8 years ago.

Were both of the same codes setting before the crank sensor was replaced, or just one or the other?

 

Were the codes cleared after the crank sensor was replaced and then they both came back?

Does the engine not start at all?

Customer: replied 8 years ago.
when the truck first died p0320 only then kept trying to crank and p0340 appeared also did not clear computer yet i own a gas station and live 40 miles away came home with cranck sensor to save money for tow did it in my driveway still wont run
Expert:  sprinkles08 replied 8 years ago.

Do you have a voltmeter to do some testing?

 

Where did you buy your replacement sensor?

Customer: replied 8 years ago.
local part store maybe this is the problem wouldnt be first time i have a meter
Expert:  sprinkles08 replied 8 years ago.

Let's start by disconnecting the crank sensor, and turn the key on.

 

Put the black lead of your voltmeter on battery ground and set the meter to 20v DC.

 

Use the red meter lead to probe each wire in the sensor connector and let me know what you see for each wire.

 

Customer: replied 8 years ago.
have to try tommorow at work when i tow it there but what am i looking for at each wire??
Expert:  sprinkles08 replied 8 years ago.

Two wires should have 5v and the third (black/light blue) should be 0. Also check the resistance to ground on the black/light blue wire. Let me know what you see for all of these and we'll go from there.

 

Customer: replied 8 years ago.
thanks
Expert:  sprinkles08 replied 8 years ago.

You're welcome!