How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Jaguar Technician
Category: Jaguar
Satisfied Customers: 15508
Experience:  12 years at a Ford/Lincoln Mercury and Jaguar dealer as technician and shop foreman.
10437779
Type Your Jaguar Question Here...
Richard is online now
A new question is answered every 9 seconds

I had to change the battery in my 2000 xj8L, and now the

Customer Question

Hi..I had to change the battery in my 2000 xj8L, and now the engine cranks fine, and was running great before but it will not start.. I read that it is due to security system...how can I fix? My car is stranded..!
Submitted: 1 year ago.
Category: Jaguar
Expert:  Richard replied 1 year ago.

Yes it could be the security. Try disconnecting just the negative battery terminal cable for about ten minutes. Then reconnect it and lock then unlock the driver door using the key in the door lock cylinder. Let me know.

Customer: replied 1 year ago.
That didnt do it, Richard. Any other suggestions? It is cranking, and the fuel pump was tested and is fine...let me know what you think....still stranded...!
Customer: replied 1 year ago.
just to add, everything was working perfectly before this battery change....I also had the new battery tested, it is fully charged, and the battery specs ate identical to the oem battery specs....thx...
Expert:  Richard replied 1 year ago.

We should check the fuses for power to make sure none have blown. You can also try spraying some crab cleaner into the air intake tube to see if the engine will start and run on the spray. Also see if the engine will start in neutral.

Customer: replied 1 year ago.
Ok, I will try that today and get back with you...
Expert:  Richard replied 1 year ago.

Let me know.

Customer: replied 1 year ago.
I pulled and checked the fuses from the trunk fuse box and the 2 under-hood fuse boxes. One 30A fuse in the trunk was bad, as was one 30A fuse in the front most under-hood box. Replaced them both. Located the inertia fuel cutoff in the passenger front seatside footwell, and depressed in with ignition on. Also did the security turn-off protocol again. Car still will not start, and battery is still 100%. Please advise...
Expert:  Richard replied 1 year ago.

Will it start if you spray some crab cleaner into the air intake tube?

Customer: replied 1 year ago.
Tried carb ckeaner...didn't work.......called a local mechanic to take a quick look and based on listening to it crank just once, he said it was a bad timing belt....I'm not sure I trust that......thoughts? Suggestions? I need to get this thing started...