How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask eauto Your Own Question
eauto
eauto, The Car Guy
Category: Hyundai
Satisfied Customers: 18236
Experience:  ase certified, imac, macs, bridhestone certified
6149662
Type Your Hyundai Question Here...
eauto is online now
A new question is answered every 9 seconds

I own a 2004 Santa Fe 2.7. Approx 119k miles automatic. When

Customer Question

I own a 2004 Santa Fe 2.7. Approx 119k miles automatic. When accelerating the vehicle acts lagging and will sometime go from 2nd to 3rd, but never up to 4th. When I select manual shift I can get it to go to 4th but never get above 62mph. The vehicle acts like it had no power when accelerating at all.... I cleaned and replaces the TPS today hoping for a smoking gun but no luck. The ECL light finally came on...But only after TPS replacement, unsure if it is coincidental or it goes hand in hand. Thoughts?
JA: Is the power loss consistent, or does it fluctuate?
Customer: Fluctuate at times... For instance when I floor it, it stalls at the speed. When I ease onto the gas it lags but does accelerate slowly
JA: Are you fixing your Santa Fe yourself? What have you tried so far?
Customer: I have a friend's that's an ASE mechanic. He is out of town so I'm limited
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 12 months ago.
Category: Hyundai
Expert:  eauto replied 12 months ago.

Hi . Thank you for asking your question on JustAnswer.

have you scanned for codes yet?

Customer: replied 12 months ago.
Prior to replacing the TPS I didn't have any ECO lights. After the replacement and driving approx 10 miles I got the light. So as of now I'm unsure what the associated code is
Expert:  eauto replied 12 months ago.

well thats the first step...does it seem like its lacking power maybe from a restricted exhaust?

Customer: replied 12 months ago.
I thehaven't checked exhaust. The vehicle did sit while I was deployed for approx 4-5 months. This issue was not happening prior to me leaving. If not the exhaust what would be your thoughts? I thought about the VSS.
Expert:  eauto replied 12 months ago.

i think its lack of fuel pressure or a melted down catylitic converter