How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Mike V. Your Own Question
Mike V.
Mike V., Hyundai Technician
Category: Hyundai
Satisfied Customers: 25687
Experience:  I have over 25 yrs. experience on all makes and models. Factory trained for Subaru and Nissan.
2921078
Type Your Hyundai Question Here...
Mike V. is online now
A new question is answered every 9 seconds

I just bought a 2012 Hyundai Accent GLS 1.6 with 87,000

Customer Question

I just bought a 2012 Hyundai Accent GLS 1.6 with 87,000 miles. Upon starting it idles perfectly but when pressing the gas pedal there is no response. In neutral I can get the RPM to bounce slightly with the pedal. I read online to press the accelerator very slowly and this helped me increase my RPM to 2000 but still very little response from throttle. Any help would be appreciated I've checked all fuses and relays there is a CE light but I haven't gotten it home to scan it yet. Thank you.
Submitted: 2 months ago.
Category: Hyundai
Expert:  Mike V. replied 2 months ago.

Thank you for your question!
My name is ***** ***** give me a moment to review your question and type my reply. Thanks

Expert:  Mike V. replied 2 months ago.

Is the check engine light on when it's running?

Customer: replied 2 months ago.
it is.
Expert:  Mike V. replied 2 months ago.

Ok, do you happen to know what code is being stored or no?

Customer: replied 2 months ago.
No not yet but I will tonight.
Expert:  Mike V. replied 2 months ago.

Ok

From the sounds of it, there is either a problem with the electronic throttle body or the accelerator pedal position sensor. This will put the car into fail safe and it won't really accelerate like it should. I would get the code if you can and it will guide you in the right direction. Once you have the code, post it with me and we can work on it. Also, you might try disconnecting the battery for about 30 minutes to see if it resets. Otherwise it does sound like it's in fail safe mode and these are usually the two culprits that will do that.

Please let me know if there is anything else I can do to help.
Just Answer does not compensate me for my time and resources, so please rate my answer by using the stars at the top of the page. Payment for your question includes any follow-up questions you may have. Free trials and subscription questions still require ratings.
Thank you so much!