How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask 350matt Your Own Question
350matt
350matt, Engineer
Category: Hyundai
Satisfied Customers: 21628
Experience:  Mechanical Engineer BEng Hons 22 years experience in car engine industry, 10 years in formula 1
12772297
Type Your Hyundai Question Here...
350matt is online now
A new question is answered every 9 seconds

I got in my 13 Veloster tonight. I was driving and the and

This answer was rated:

I got in my 13 Veloster tonight. I was driving and the and the rpm were revving . The Drive symbol was flashing but no dash symbols were on. My radio did however kept showing a message "Protection mode enabled"
JA: Is this an aftermarket stereo, or did it come with the car?
Customer: I take really good care of my car. No sir
JA: Are you fixing your Veloster yourself? What have you tried so far?
Customer: no sir .
JA: Anything else you want the mechanic to know before I connect you?
Customer: It has less than 41,000 mile

Hello

I'd start by checking the fuses and main battery connections, check that they are bright and tight with no signs of corrosion

and I'm assuming that this is an automatic transmission so I'd take a look at the colour of the transmission oil it should be a dark red colour if its black then its needs changing together with its oil filter. Also check its level with the gearbox warm and just after you've moved the selector through all the positions leaving it for a few seconds in each one and then back to park.

You can top up the box through the side fill plug if required and make sure you use the correct oil for your car as the fluids are not all the same. Some manufacturers recommended a change of the type of fluid - Speak to the local dealer and parts dept - they will advise you on the updated fluid to use..

If that’s all OK then check all the electrical connections of the gearbox, remove each connector in turn and spray with contact cleaner. Check that the wiring to the gearbox is in good condition with no chafing or frayed wire

If this is OK then check the selector lever linkage / cable under the car for any broken parts and or missing bolts as if this is coming adrift then it can rub on the car body or just bind up

Then - you should top up if low and re try it - or, if its level is ok - and condition is ok - then the next step is to drain it off - open it up and clean the filters inside -- refill and retry it..

Hi

do you still need help?

Bear in mind that the site takes a deposit from you at the beginning and this is held by the site until you rate my answer at which point the cash is split between the site and the expert. I am only paid for my work on this question if you rate my answer, using the star system at the top of the screen. Please do not forget! Thank you

350matt and 3 other Hyundai Specialists are ready to help you