How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask K. Wiggins Your Own Question
K. Wiggins
K. Wiggins, ASE Certified Technician
Category: Hyundai
Satisfied Customers: 2992
Experience:  ASE Certified Technician, Associates Degree in Automotive Technology, 15+ years in the trade
68360881
Type Your Hyundai Question Here...
K. Wiggins is online now
A new question is answered every 9 seconds

My name is ***** *****. My problem is on a 2004 Hyundai

Customer Question

Customer: My name is ***** *****. My problem is on a 2004 Hyundai Sonata 6 cyl 2.7 L.
JA: Thanks. Can you give me any more details about your issue?
Customer: Sorry hit the wrong key. Ok just changed the timing belt, the crank position sensor, and new plugs. Had the car running for 2 days a little plugs. codes read at Oreileys says # ***** and 6 cyl misfiring. but on my way home last night the car slowly lost power until it finaly died and wont start back up. it tries to fire over but it just wont completey ignight
JA: OK got it. Last thing — JustAnswer charges a fee (generally around $18) to post your type of question to Hyundai Experts (you only pay if satisfied). There are a couple customers ahead of you. Are you willing to wait a bit?
Customer: yes
JA: OK. Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Hyundai
Expert:  K. Wiggins replied 1 year ago.

Hello, have you pulled the timing cover to see if the marks still line up or performed a compression test?

Customer: replied 1 year ago.
triple checked. Just reconfirmed that i gave fuel pressure.
Customer: replied 1 year ago.
She wants to fire when i hold the pedal to the floor but just cant quite get there
Customer: replied 1 year ago.
Could an O2 sensor be causing this? The only codes i got yesterday were for a faulty O2 sensor and # ***** and 6 cyl missing
Expert:  K. Wiggins replied 1 year ago.

Thanks, ***** ***** sensor would not cause this. If it's wanting to crank with throttle to the floor (clear flood mode) I would check the plugs on 3and 6 nd the cylinder next to them and see if 3 and 6 have raw fuel on them compared to the adjacent cylinders. Reason being an injector could be stuck or a wire may be pinched fiirng it all the time.

It would also be a good idea to place a noid light on each injector to make sure they are firing properly. When firing properly the light will blink if it stays on solid there is an electrical problem causing the injector to fire all the time.

Let me know what you find and we can work further.

Customer: replied 1 year ago.
The plugs are bone dry. IT started this morning for a minute was able to rev it up to just under 4000 then again it just died. As i stated earlier took it to work yesterday with it missing and it was fine but on the way home she started loosing power it was all i could due to get it going from a start and to maintain speed until it just died. I have double checked the fuel pump at 3 different locations checked spark with an inline tester all fine just dont get it cause it fires for a min if i leave it be for a few hours then just dies
Expert:  K. Wiggins replied 1 year ago.

Thanks, I'm going to open this back up to other experts to see if anyone else has some thoguhts on this. Someone should be with you shortly.

Customer: replied 1 year ago.
Thanks
Customer: replied 1 year ago.
Ok for the new mech. I have a 2004 Hyundai Sonata 2.7 l 6 CYL. The timing belt snapped a few weeks ago so I installed a new one. The engine warning lite came on and it ran real rough at an idle. so I went down to Oreileys and put it on their comp. It came bake as an crank sensor error and # ***** & 6 CYL misfireing. So I installed a new sensor the eng warn light went out for about 5 min then came back on and she ran real rough at idle and was troublesome to get going. Back to Oreileys this time it read O2 sensor and # *****&6 cyl missing. Put my inline spark tester on all lines and they all fired real strong so I installed 6 new plugs. NO HELP. I drove it to work yesterday as is. No new probs went to lunch no new probs BUT on the way home she started loosing power hard to maintain speed. At stops it was nearly imposible to get it going and to increase speed just acted like it wasent getting fuel then it just died and wouldent refire. This morning I went to get it and it fired up for about a minute but I was only able to rev it up to 4000 then it died and wouldent refire. got it towed home and tried it again ran for a min and only 4000 rpms then it died and wont refire. So I disconnected the return fuel line at the tank turned the ign on and it pumped fine so I left it off and tried starting it again and filled a 2Lt bottle with gas in no time. I then disconnected the feed line at the rail again great fuel flow then disconnected the return line on the back of the rail just fine. So I have fuel I have spark and I have intermittent firings but nothing else. could that bloody new crank sensor along with a bad O2 sensor be causing this head scratcher?