How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dan Your Own Question
Dan
Dan, Technician
Category: Hyundai
Satisfied Customers: 24579
Experience:  Independent Shop Experience, 2 Year Automotive Diploma, & Access to Information Database
17871496
Type Your Hyundai Question Here...
Dan is online now
A new question is answered every 9 seconds

Ok i have a 2007 Hyundai and the issue is the r/s low beam

Customer Question

ok i have a 2007 Hyundai and the issue is the r/s low beam is not working , i changed the bulb and still doesnt work, the high beams do work, but used a digital volt meter at the bulb plug and it some how made a pop sound and now the high beams don't work ..lol the power center is in the engine compartment and the relay and fuse are good... #12 fuse and I switched the relays and it is clicking when you try to turn on the brights... Help ..?
Submitted: 2 years ago.
Category: Hyundai
Expert:  Dan replied 2 years ago.

Hello, my name is***** model Hyundai? Thanks

Customer: replied 2 years ago.
2007 sonata 4 cylinder
Expert:  Dan replied 2 years ago.

Sorry about delay, website did not notify me. Give me a couple minutes to look up wiring. Thanks.

Expert:  Dan replied 2 years ago.

Does the left side low beam work?

Expert:  Dan replied 2 years ago.

Also, do you heave daytime running lights or automatic headlights? Thanks

Customer: replied 2 years ago.
the l/s low beam is working... the high beam isn't now... it was and Quit ... when you turn the knob to Auto the left side headlight works and the parking lights work .. nothing on the r/s except the marker light in the headlight assy ...
Expert:  Dan replied 2 years ago.

Check the 20 amp H/LP HI fuse in fuse box under hood. That will probably take care of hi beams

Expert:  Dan replied 2 years ago.

Low beam most likely means you have a bad ground. Check the black wire going to low beam for good ground, if weak or no ground run to new ground or clean where wire grounds out. Let me know if you have more questions or run into questions. Thanks.

Customer: replied 2 years ago.
oki i will check the fuse again, but all the fuses had voltage on both sides of the pins on the top of the fuse.. meaning they are not blowen correct..? the ground seamed ok but i will check it with an ohms meter ... i kinda went threw all the simple stuff.. not sure why when i was checking the voltage at the headlight bulb spade connector that it would cause that snapping sound like a fuse, but yet all the fuses show to be good... i will check again and let you know...
Expert:  Dan replied 2 years ago.

Check to see if fuse is blown, if not check to see if it has voltage. Keep me updated on findings, thanks.