How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Greg Your Own Question
Greg
Greg, import technician
Category: Hyundai
Satisfied Customers: 7053
Experience:  27 year and 16 year as shop owner, import technician
29331485
Type Your Hyundai Question Here...
Greg is online now
A new question is answered every 9 seconds

I have a 2006 hyundai tucson, whenever I turn the A C on the

Customer Question

I have a 2006 hyundai tucson , whenever I turn the A C on the car starts to run differently and shuts off eventually . It starts back up right away but I'll have to turn the A C off. A few people checked it and said I needed an O2 sensor , but now they cant seem to find an old one nor the harness to connect a new one in case somebody moved the old one. My question is does my vehicle come with the O2 sensor, where would the harness be located if it does, or what might the real problem be in my vehicle.
Submitted: 1 year ago.
Category: Hyundai
Expert:  Greg replied 1 year ago.
Name is***** goal is to provide you with excellent service – if you feel you have gotten anything less, please reply back,
Could you tell me if you have any malfunction codes
If yes what are they .
How many miles has it done .
Rgds Greg
Customer: replied 1 year ago.
No malfunction codes, and 61000 miles
Expert:  Greg replied 1 year ago.
Hi
If no malfunction codes then the O2 sensors are correctly fitted and working .
When you switch ON the ignition does the check engine light come ON and go out when the engine starts .
Can you keep the engine running if you switch on the A/C and rev up the engine and is the A/C cold .
Greg
Customer: replied 1 year ago.
No check engine light does not come on. Yes I can keep engine running if I switch A/C on and Rev up engine, but the engine does not run as smooth as it does without the A/C , it feels as though it's sputtering a bit and I cannot reverse the car with the A/C on because it feels as though the gears are stiff and the vehicle might shut off. But the A/C is cold
Expert:  Greg replied 1 year ago.
Hi
Okay thank you ,you need to get the car to a good repair shop or dealer as when the check engine light does not come on with the ignition this is a sign of a malfunctioning ECM .
You may need to have the ECM re-flashed to fix this issue .
If the check engine light was working and you had no codes then i would say the IAC is causing you this issue or a bad A/C compressor dragging down your engine which is a common issue .
If needed please get back to me with the reply button, and not the poor or bad service, this way i can get back to you or suggest another expert if needed.
Your deposit does not pay me until the answer is rated in a positive way,
Not rating or a bad rating does not constitute a refund.
If you are not happy or you have sorted out your problem before the answer then please let me know with the reply button .
Kind regards Greg.