How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Neal Your Own Question
Neal
Neal, Auto Mechanic
Category: Hyundai
Satisfied Customers: 8351
Experience:  Shop Owner and Mechanic on multiple makes.
17294534
Type Your Hyundai Question Here...
Neal is online now
A new question is answered every 9 seconds

I am getting a sparking under the cam shaft. i changed the

Customer Question

I am getting a sparking under the cam shaft. i changed the camshaft sensor, the cam shaft pulley and the plug wires. There is no sparking when engine is cold in the morning but after about ten or fifteen minutes of driving it starts to spark. Any ideas?
Submitted: 1 year ago.
Category: Hyundai
Expert:  Neal replied 1 year ago.

Can you explain a little more about the sparking? Are there literally sparks showing? And exactly where do you see them?

Customer: replied 1 year ago.
We see the sparking on the camshaft when we go under the car,. Standing in front the car you can hear the spark like every couple seconds pax pax. Now and then when driving a slight misfire occurs but otherwise the car works normally.
Expert:  Neal replied 1 year ago.

First make sure you have a good ground from the battery to the engine. If thee engine is not properly grounded to the battery it can cause problems like that. Are you getting a engine code for a misfire or a check engine light?

Customer: replied 1 year ago.
No check light, all the diagnostic said was random misfire, which the guy said was us removing the plug wires to check
Expert:  Neal replied 1 year ago.

Clear the codes and then when the code reappears, try replacing that plug wire or all of them to see if it is just a bad plug wire.

Customer: replied 1 year ago.
I have put in a complete set of new plug wires
Customer: replied 1 year ago.
Could it be the plugs themselves?
Expert:  Neal replied 1 year ago.

After the codes are cleared, what code comes back first? It is unlikely that is the plugs, but it could be a broken coil that is shorting out to the engine.

Customer: replied 1 year ago.
I cannot say about the codes, i am not by the diagnostic now. Can you suggest something that i can try.I have almost given up.
Customer: replied 1 year ago.
Change the coil?
Expert:  Neal replied 1 year ago.

I would try the coil next if I were you.

Customer: replied 1 year ago.
Sorry for the delay i had a visitor, Ok thanks for the help , i will check on the coil
Expert:  Neal replied 1 year ago.

Let me know what you find.

Customer: replied 1 year ago.
Ok i will thanks
Expert:  Neal replied 1 year ago.

You're welcome!!

Customer: replied 1 year ago.
It is the crankshaft not the camshaft. I changed the coil pack but the sparking is still there. I just do not know what to do next. I am driving with the spark. Its funny that the first ten minutes in the morning there is no sparking.
Expert:  Neal replied 1 year ago.

And you made sure the battery ground is good?

Customer: replied 1 year ago.
i NOW HAVE TWO GROUND WIRES. THERE IS A NEW ONE AND I HAVE RECONNECTED THE OLD ONE.
Expert:  Neal replied 1 year ago.

Are you getting any codes now?

Customer: replied 1 year ago.
diagnostic shows up nothing. All ok
Customer: replied 1 year ago.
The only other thing that i can think of is that the green ignition light on the dash goes on and off at times
Expert:  Neal replied 1 year ago.

The only other thing I can think of is that the alternator could be shorting to the engine. But I would think it would be grounding through the ground cable.

Customer: replied 1 year ago.
Ok thanks Neal, I will work on that one and get back to you. It is possible because i changed the alternator recently [a used one] after the original one was making a bearing noise.
Customer: replied 1 year ago.
Checked the alternator but sparking still there. I have also changed the coil pack. i am now thinking maybe it is something in the wiring as the green drive light keeps going off and coming back on.