How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Phil Your Own Question
Phil
Phil, Mechanical Engineer
Category: HVAC
Satisfied Customers: 6022
Experience:  Retired HVAC/ Electrical & Boiler contractor. Industrial
23932409
Type Your HVAC Question Here...
Phil is online now
A new question is answered every 9 seconds

Dunkirk 100 SN 25070096 10 years old. already replaced IBC

Customer Question

Dunkirk 100 SN 25070096 10 years old. already replaced IBC and transformer. worked overnight after reset blower works indicator lights show power lit, purge lit, and flame lit. it does not go to ignitor and valve can this be an air pressure switch problem?
JA: Did you double-check the thermostat's settings? And what about the filters?
Customer: Which thermostat settings? I had them hot water calling for heat. Air vents are clear
JA: Do you plan on doing the work yourself?
Customer: yes
JA: Anything else we should know to help you best?
Customer: No I know that the IBC will tell you what is wrong and the flame lite on when there is no flame indicates something
Submitted: 3 months ago.
Category: HVAC
Expert:  Rick replied 3 months ago.

Welcome to Just Answer, my name is ***** ***** I will do my best to help you with your

issue. First I’ll need some more info so I have a more complete picture of your situation.

Have you inspected the igniter or ohmed it out? do you have power to the igniter?

Customer: replied 3 months ago.
as I said it worked fine all day yesterday after the IBC was replaced and the transfromer. The trouble shooting all pointed towards the IBC After reset the power and purge light come on and blower runs but so does the flame light and there is no flame
Expert:  Rick replied 3 months ago.

You really didn't answer my question. Did you test or inspect the igniter since it went down?

Expert:  Rick replied 3 months ago.

If igniter and valve LED don't light up but the flame LED lights up then you have a control issue. Try power it down then power it back up. Tell me what happens