How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Daniel Plourde Your Own Question
Daniel Plourde
Daniel Plourde, HVAC Technician
Category: HVAC
Satisfied Customers: 327
Experience:  hvac technichian at performance plumbing and heating
89712187
Type Your HVAC Question Here...
Daniel Plourde is online now
A new question is answered every 9 seconds

I have a aircomfort system i 't have any heat coming out of

Customer Question

I have a aircomfort system i don't have any heat coming out of it. so i checked the thermo switches that are mounted all over they are all closed..check transformer for 24v that was good so i purchased a new board which is different than original. old board ST9120C4016, and the new one is ST9120B i was told was the direct replacement for the old board. the schematic isnt exactly as direct as i would like i can get the heat fan to work or the lower whole house fan to come on even both but i can not turn off at thermostat not does the heater strike on. can you help.
Submitted: 1 year ago.
Category: HVAC
Expert:  Daniel Plourde replied 1 year ago.

hi i am dan i can help you with this. first is the new board installed now or the old board?

Customer: replied 1 year ago.
I just installed the new board for the second time
Expert:  Daniel Plourde replied 1 year ago.

ok and what was the problem when the new board is installed that it wont heat or the heat doesnt turn off?

Customer: replied 1 year ago.
It won't heat..And actually I seem to have no control from thermostat..I held in the safety switch had the wife turn on to 80°...wouldn't fire up
Customer: replied 1 year ago.
When I hold in switch motors stay on cant shut down from thermostat either
Expert:  Daniel Plourde replied 1 year ago.

ok i assume you mean the switch for the blower door and what is the status of the led lights on that board when the fan continuously runs

Customer: replied 1 year ago.
Also the new board has a status light but ive never seen it come on..yes the switch is for the blower door
Customer: replied 1 year ago.
I was watching for it...they said if dimly lit but constant system is good
Customer: replied 1 year ago.
No light at anytime
Expert:  Daniel Plourde replied 1 year ago.

ok are you able to take a picture of the circuit board installed showing all the wiring connections and post it here. that would be a lot easier for me to see what is going on and help you diagnose it.

instructions for attaching files

Customer: replied 1 year ago.
Sure I can give it a shot
Customer: replied 1 year ago.
Ok I snaped some shots
Expert:  Daniel Plourde replied 1 year ago.

i have not got anything. you have to attach them to your post

Customer: replied 1 year ago.
Sorry give me a minute
Customer: replied 1 year ago.
Expert:  Daniel Plourde replied 1 year ago.

ok got it. give me a minute to review them

Customer: replied 1 year ago.
No prob.
Expert:  Daniel Plourde replied 1 year ago.

ok first i see alot of incorect wiring conection so i will mark it up for you to correct but it will take some time. no need to reply as the system requires a response from me every time you post but i will get back to you in a few minutes

Customer: replied 1 year ago.
This ids the main drawing I used to hook up
Expert:  Daniel Plourde replied 1 year ago.

yes and you do not have an electric air cleaner for a filter correct?

Customer: replied 1 year ago.
Ok I sent you a drawing I did move some thermostat wires and left them for now the old system had a brown and white on top and a red and white together just fwi...the other issue was with the blower door switch the drawing really have the same hook up as the old one caused some confusion...if you don't mind I need to get some sleep I work tonight I can check your response later Dan.
Expert:  Daniel Plourde replied 1 year ago.

ok that is fine

Customer: replied 1 year ago.
That is correct
Expert:  Daniel Plourde replied 1 year ago.

ok as i said you do not need to reply as it requires a response from me

Customer: replied 1 year ago.
Idont have a humidifier either
Expert:  Daniel Plourde replied 1 year ago.

ok

Expert:  Daniel Plourde replied 1 year ago.

i have drawn up the corrections for the wiring. if you can correct this wiring and install the board securely where the old board was and change the dip switches as i have marked the way they should be set and install a 3 amp fuse and turn the furnace back on we can see if it works now or continue troubleshooting from there. i will also send you a phone call offer if it will be easier for you to explain it over the phone or if you have any questions about the wiring just reply back here.

Customer: replied 1 year ago.
Hey Dan, yea I pulled the fuse to check it with my meter, I'll put it back...question on the dip switches I didn't mess with them because it appears to be potted if so should I try and dig them out when I looked at last I was trying to see uhf it were a cover ooh some sort..but I got to say it looked to be potted.
Customer: replied 1 year ago.
I got your drawings thanks ,haven't tried yet, but will.
Expert:  Daniel Plourde replied 1 year ago.

They are not potted. It is just tamper tape over it so the factory knows if it was used when returning. Just push it with a small screwdriver or meter leed.

Customer: replied 1 year ago.
Ok thanks Dan, ill try when I get home in the morning
Expert:  Daniel Plourde replied 1 year ago.

Ok let me know

Expert:  Daniel Plourde replied 1 year ago.

is your furnace still not working or did that fix it?