How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Dustin Your Own Question
Dustin, Senior Technician
Category: GPS
Satisfied Customers: 13454
Experience:  Giving Directions to wayward GPS devices for over a decade. Worked in The US Army as A Network Switching Systems Operator/Controller
Type Your GPS Question Here...
Dustin is online now
A new question is answered every 9 seconds

In the thread "I was in the middle of my DEZL 560 SW and

This answer was rated:

in the thread "I was in the middle of my DEZL 560 SW and maps update, GARMIN" you eventually did a screen sharing session. I have the same problem. How did you finally resolve that one?

Welcome to, my name is Dustin.
I'm sorry to hear about the issue you are having, I will do my best to help you resolve it.

I cannot see the thread you are referencing, but it sounds like that a firmware cure / flash was suggested or carried out.

Before I speak or try to assist you directly with your issue, can you describe the exact and current status of your issue.

What exactly happens when you turn the Dezl on, when did this start, if you receive any error messages what are they full and precisely?

Thank you,

Dustin S.

Senior Technician and Network Switching Systems Operator / Maintainer.

Customer: replied 11 months ago.
Here is a link to the thread
I haven't done any of the steps in the thread but I have exactly the same problem and symptoms.I was doing a yearly update using Garmin Express -- OS update and 9 map/languagepack/... updates.
Following the instructions GE first did the OS update then instructed me to unplug the unit from the USB port, turn it on, let it boot then replug it. During the boot the map file load was at 80% when the unit timed out. I believe it was set to go off after two minutes when not on power but I am not positive of that. I turned it on again, the map load ran to completion and I got the regular home screen after the automobile mode note.I then plugged the unit back into the usb and GE picked up, completing the rest of the downloads. It said it was done so I took the unit off the usb -- it shut down.When I put the unit in the vehicle it started a continuous reboot cycle: Garmin Logo, copyright screen, loading maps note, black screen, Garmin LogoIt does the same thing on USB and does not show up as a USB device to the computer.I tried a hard reset (lower right) -- get system, system, system for a while then loading then back to Garmin Logo.I tried to the "storage mode?" (upper left) and got the same behavior except that I did get to the recalibration dot. But at that point if I let up on the upper left it goes back to the reboot cycle.So that's it so far.

Great detailed explanation..

You definitely have corrupted firmware, and we need three things.

The garmincure3.exe program, updater.exe and an original copy of the dezl 560 rgn file.

The last one , the rgn file is what I need / hope to find.. Without it, we cant repair the unit ourselves.

Please allow me some time to search my souces for that file.

Dustin S

Customer: replied 11 months ago.
KK. What did I do wrong to cause this? How can I avoid it in the future? FWIW, the unit did not have a micro-SD card in it when I did the update.
Customer: replied 11 months ago.
Also -- device is dezl 760LM Sn 2RY076850 in case the FM is specific to that model and block

Thank you.

Ive found the file needed. From this point forward it would be best if you and I connected via a screen sharing session and spoke over the phone. The firmware flash process can be a bit tricky, and it literally takes two sets of hands. One of us needs to have our hands on the unit itself and the usb cord and the other needs to have their hands on the mouse so we can click the updater in the brief second it will flash the Dezl model on the updater screen.

I will send the offer for the screen sharing session to you now. It will be an additional fee. With that being said, If I am unsuccessful you will be entitled to a full refund of all fees.

Once you have accepted or rejected this offer please respond so we can figure out how to continue.

Dustin S

Customer: replied 11 months ago.
Thanks for your help so far. I won't be able to set up a screen sharing session. If you could forward me links to the files and instructions I'd appreciate that though.
Customer: replied 11 months ago.
Thanks, ***** ***** won't be able to set up a screen sharing session. If you could send me links to the files/instructions I appreciate that though.

First, you need this GCD file. Note, you must have a windows PC, not a mac or a chromebook.

Download it, and save it.. Then next, you need two programs.

garmin cure exe and updater exe.. Y ou can get them both from the dropbox link on this page

Once you have downloaded garmincure exe and updater exe.

Use garmin cure, load the gcd file we downloaded first, then click make firmware.

It will output a rgn file.. Use that rgn file and load it into updater exe.

Next, you h ave to hold the upperleft hand corner of the screen , and then turn on the Dezl while plugging the usb cord into the computer AND you have to watch the updater exe screen and for a split second you will see it flash the DEZL as a USB device.

In that split second you must click ok to start the flash and click ok again to proceed with the flash.

This will work. But its tricky at best to get it going and extremely difficult on your own.

ONCE y ou have done this successfully.. You only have a cure firmware.. To get the dezl workig normally

You now need to download and install the webupdater, and let it update the unit itself to the newest firmware

Here is the link for the web updater

Once that update is complete, finally you need to disconnect the device, t urn it off and on and reconnect it to the computer.. Then, run the garmin express program and let it update the maps and software one last time.

Now, you have a working unit.

T he process above is tough, and difficult. But IT will work, and it will fix the issue.

best of luck to you, and if you have further questions let me know.

I strive to provide great service, and greatly appreciate a 5 star rating clicked and submitted when you are satisfied.. I always answer follow up questions.

Dustin S.

Senior Technician and Network Switching Systems Operator / Maintainer.

Customer: replied 11 months ago.
Thanks for all the help. I've downloaded the files and will try it out in a bit. One more thing... could you help me understand what I did to cause this and how I can avoid it in the future?

The reason this happened is that the update was interrupted.

Anytime an update gets interrupted theres a 50-75% chance the firmware will corrupt.

How to avoid this in the future.. Make sure your antivirus is off when you do the update.

make sure you are on a solid, stable internet connection

Never update over sattelite internet, or cell phone / mobile hotspot internet.

Make sure you do not bump the computer, touch the usb cord, or bump the garmin. ( If it loses usb connection for just a second, that will interrupt the update )

Also. make sure the device is at least 50% charged. And make sure your computer isnt set to go into screen saver or sleep mode when idle. Changing the computers power performance plan to high performance will help a lot during the updates.

That about covers it.. Whether or not you run into issues with the firmware creation, flash, update, and repair.. Please respond when you can and let me know the outcome or if you need further help.

I strive to provide great service, and greatly appreciate a 5 star rating clicked and submitted when you are satisfied.. I always answer follow up questions.

Dustin S.

Senior Technician and Network Switching Systems Operator / Maintainer.

Dustin and other GPS Specialists are ready to help you
Customer: replied 11 months ago.
A follow up for you... I've been pursuing this with Garmin as well. At first they gave me the "out of warranty" answer. I pushed back and said the working unit failed doing a normal update with Garmin stock software. They responded with an offer of an RMA and a replacement unit. The paperwork has not cleared but I believe it will. As a result I'm not trying out your solution yet. I don't want to send them back a unit with modified software. If the detail falls through I will try out the solution you've provided. Many thanks for all your help so far.

Not a problem at all.. And I also hope the RMA goes through.. if it doesnt, what I can say is after the process completes, you wont be running modified software.. Rather, you would be running the standard and current firmware for the unit.

And even the firmware file we used to start the flash was a standard garmin firmware, just an older version which helps "cure" the device..

Hopefully the RMA goes through and thank you for keeping me posted.

Dustin S

Customer: replied 11 months ago.
FYI -- I _did_ sign off on your payment. You went through the work, found the image, and passed the instructions on to me. So good job. It sounded from your last note like you might have thought I was holding up payment until I found out about the RMA. I wasn't.

Thank you, ***** ***** already cleared before I had replied.

I just wanted to make sure you knew that if something went wrong with the RMA, Id continue to follow through with you so we could fix the issue via the firmware flash process.