How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Richard Your Own Question
Richard
Richard, Customer Service
Category: GPS
Satisfied Customers: 36777
Experience:  Avid repairer and trouble shooter of GPS devices and systems
32989067
Type Your GPS Question Here...
Richard is online now
A new question is answered every 9 seconds

I have a 2013 Jeep Patriot with a built in Garmin. Last

Customer Question

I have a 2013 Jeep Patriot with a built in Garmin. Last month it was loading slow to get to the navigation part, now in the last 2 weeks it wont load at all....it just keeps on the all black screen that says Garmin, and every minute or so, it will flip like its going to load, but then goes back to the same screen. I travel for a living, so I'm lost without my navigation....Please Help!!
Submitted: 1 year ago.
Category: GPS
Expert:  Richard replied 1 year ago.

Hi there Erin and welcome

Can chance you can give me the model of the Garmin please?

Thank you

Customer: replied 1 year ago.
Where would that be located?? its built in to the car.
Expert:  Richard replied 1 year ago.

On the manual that came with it or the packaging, but if you do not have this then I want you to remove power to the unit.

To do this, you need to disconnect the battery on the Jeep

Wait 30 minutes, connect the battery, and tell me if it now starts please.

Customer: replied 1 year ago.
could it be Uconnect 130??
Expert:  Richard replied 1 year ago.

yes thats it.

Do the last instructions I gave please and let me know the results.

Customer: replied 1 year ago.
sorry....no it has to be uconnect 430/430N
Expert:  Richard replied 1 year ago.

ok, for the entire model range my instructions will apply for these

Customer: replied 1 year ago.
ok....how do I disconnect power from the battery?? I have never done anything like this.
Expert:  Richard replied 1 year ago.

You disconnect the cables from the battery terminals, so you life up the hood and locate the battery and disconnect first the positive terminal with the + and then leave it for 30 minutes,

Customer: replied 1 year ago.
car on or off??
Expert:  Richard replied 1 year ago.

off as your removing power to it.

Customer: replied 1 year ago.
ok...sorry for the silly questions, like I said, ive never ever done anything on my car. so I do that, leave it off for a half hour, then reconnect and see if it loads and let you know??
Expert:  Richard replied 1 year ago.

its no problem, so you need to open up the hood of the car, where you see the motor. There you see the battery and you remove the + Terminal, and be careful with this.

Then wait 30 minutes, put the terminal back on so you again have power to the car, then try the navigation please.

Customer: replied 1 year ago.
battery back on, car started, still no naviation
Expert:  Richard replied 1 year ago.

still frozen on the Garmin screen?

Customer: replied 1 year ago.
just keeps going from plain blact to the guidance by garmin loading screen
Expert:  Richard replied 1 year ago.

Thanks

It is the internal memory in the unit that has faulted.

A corrupted firmware can cause this. But we have ruled this out by trying to hard reset it.

I am really sorry about this and you are going to have to return the car to have the unit replaced. It will be covered by the warranty if this has not expired, and the replacement will be done at no cost to you.

I am really sorry about this, and if you have problems, or would like any additional information or assistance, please do not hesitate to let me know.

And if you can take a second to rate my service by clicking one of the stars at the top of the page, then submit, that would be greatly appreciated.

Thank you

Customer: replied 1 year ago.
am I going to be charged the 40 dollars for this????
Expert:  Richard replied 1 year ago.

It is for the service you paid. We went through and eliminated all issues that can cause this, which in most cases gets it to working but in your case which we confirmed, its a hardware issue and they need to replace it.

It is for this service that you played for Erin. If it was only when we fixed the issue, then no one would have help you in the event this was a hardware issue. All we can do is go through and rule everything out and if it is confirmed as a hardware problem then what you need to do. This is what we did.

Expert:  Richard replied 1 year ago.

If you would like any additional information or assistance, please do not hesitate to let me know.

And please take a second to rate my service by clicking one of the stars at the top of the screen then submit

Thank you