How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Gm Tech (Cam) Your Own Question
Gm Tech (Cam)
Gm Tech (Cam), GMC Mechanic
Category: GMC
Satisfied Customers: 29523
Experience:  GM Grand Master Technician 2007. 14 year experience.
10949255
Type Your GMC Question Here...
Gm Tech (Cam) is online now
A new question is answered every 9 seconds

My auto climate control is not working correctly I only have

Customer Question

My auto climate control is not working correctly I only have heat when ii's set to 90 all the other temp settings are cold and the fan always runs high speed. It's a 2005 GMC Sierra 2500
JA: Have you checked the coolant level? Has there been any leaking from the hoses?
Customer: No leaks, I replaced all the actuators and temp sensor still no difference, could it be the digital unit itself ?
JA: Are you fixing your Sierra yourself? What have you tried so far?
Customer: driver and pas. actuators and temp sensor
JA: Anything else you want the mechanic to know before I connect you?
Customer: no thanks for your help
Submitted: 10 months ago.
Category: GMC
Expert:  Gm Tech (Cam) replied 10 months ago.

Hi there, I am cam.
Which temp sensor did you replace?

Customer: replied 10 months ago.
the one in the roof above the driver's door
Expert:  Gm Tech (Cam) replied 10 months ago.

Ok, what does the outside temp show in the dash?

Customer: replied 10 months ago.
don't have a temp. display in the dash it's on the mirror
Expert:  Gm Tech (Cam) replied 10 months ago.

And what does it show? IS it correct for the actual temp outside?
And is the fan in the sensor in the roof running?

Customer: replied 10 months ago.
it is correct and the fan in the sensor works
Expert:  Gm Tech (Cam) replied 10 months ago.

Ok, lets try a reset.
Take the battery cables off the battery, hold the ends together for 10 seconds then attach them to the battery and see what happens. This will reset the whole vehicle.
If you have 2 batteries, then remove both and touch only one set.

Customer: replied 10 months ago.
ok I'll give it a try Thanks
Expert:  Gm Tech (Cam) replied 10 months ago.

Sure thing.