How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask sprinkles08 Your Own Question
sprinkles08
sprinkles08, ASE Certified Technician
Category: GMC
Satisfied Customers: 23117
Experience:  ASE Master and Advanced level certified. Factory trained with 17 years dealership experience
9825021
Type Your GMC Question Here...
sprinkles08 is online now
A new question is answered every 9 seconds

No communication to abs module, yes, i replaced the abs

Customer Question

HI Pearl
JA: What are all the symptoms you've noticed (e.g. noises, leaks, flashing lights, error codes)?
Customer: no communication to abs module
JA: Have you checked the brake fluid? And have the brakes been squeaking?
Customer: yes
JA: Are you fixing your vehicle yourself? What have you tried so far?
Customer: i replaced the abs module already
JA: Anything else you want the mechanic to know before I connect you?
Customer: still no communication with the abs module
Submitted: 1 year ago.
Category: GMC
Expert:  Tim Mohr replied 1 year ago.

Hi, my name is ***** ***** is the year make, model and engine in this?

Customer: replied 1 year ago.
2005 gmc savana g3500 cutaway with 6l engine
Customer: replied 1 year ago.
I can get the dtc codes but i cannot get information on data because of communication error
Expert:  Tim Mohr replied 1 year ago.

Do you have a test light or voltmeter? we need to check powers and ground at the abs module?

Customer: replied 1 year ago.
Power and ground is excellent in the abs module
Expert:  Tim Mohr replied 1 year ago.

on which pins?

Customer: replied 1 year ago.
Connector1 pinA and pinB voltage is 12.96VConnector brake fluid level switch with the key on A&B is 4.97V
Expert:  Tim Mohr replied 1 year ago.

ok, this is the problem, with the connecor disconnected, the Cavity "A" in the C1 connector is ground, it should not have power, the Cavity "B" is the power, can you recheck this?

Customer: replied 1 year ago.
C1 connector cavity "B" has a power of 12.43V
Expert:  Tim Mohr replied 1 year ago.

you said both had power, does cavity "A" show a god ground?

Customer: replied 1 year ago.
groung is good as well
Customer: replied 1 year ago.
Ground is good on that cavity as well
Expert:  sprinkles08 replied 1 year ago.

Hello and welcome to JustAnswer!

If the ABS module doesn't communicate then it's missing power, ground, it has failed, or there is a communication bus wiring issue only affecting the ABS module.

It appears you're testing power and ground feeds with a voltmeter, which won't give an accurate test result. Do you have a headlamp bulb and some jumper wires?