How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask t-fran21 Your Own Question
t-fran21
t-fran21, ASE Certified Technician
Category: GMC
Satisfied Customers: 1616
Experience:  GM Master Tech
10186415
Type Your GMC Question Here...
t-fran21 is online now
A new question is answered every 9 seconds

My rear wiper quit working after I t the garage with the lid

Customer Question

My rear wiper quit working after I hit the garage with the lid up. I stopped immediately but the motor will not run, fuse is ok I went to the junk yard and removed one from another car but it would not ru n either.
Submitted: 1 year ago.
Category: GMC
Expert:  t-fran21 replied 1 year ago.

First make sure both uses a good one is under the hood one is in the fuse block on the left side of the Dashboard both are labeled RR WPR. If the fuses are good remove the rear panel weather wiper motor is and with the key on and the rear wiper on unplug the connector from the wiper module/motor and make sure you have power on the orange wire and on the gray wire and make sure you have ground on the black wirethen you will need to close the liftgate and check for 0 V on the pink/black wire, if you have more than zero votes all the pink/black wire then you have a bad liftgate switch reply back, if everything tested good then you have another bad wiper motor module. Please give a positive rating. Thanks