How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, GMC Mechanic
Category: GMC
Satisfied Customers: 27814
Experience:  GM training and dealer tech for 14+ years. Diagnostics
14928985
Type Your GMC Question Here...
Pete is online now
A new question is answered every 9 seconds

GM Envoy: Ron, I have the same thing - blows only on speed

Customer Question

Hi Ron,
I have the same thing - blows only on speed 4. I've just bought the replacement and set it up. And... i have all blowing speeds but AC and blowing position switch stopped working.
Submitted: 2 years ago.
Category: GMC
Customer: replied 2 years ago.
Envoy 2004, 4WD, 4.2L. I got another resistor and the same result. Put back the original one - AC is working, position switch is working, blowing on speed 4 only.
Expert:  Pete replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
Since the blower control module/resistor did not work to correct this fault here this can be caused by an internal electrical fault with the heater/ac control on the dash itself.I have seen this control fail before in the past and cause incorrect or no signal issues to the resistor and cause this issue and had to replace it.The signals from the control will need checked using a scan tool or multi meter to see if it is the cause here and then replaced if found to be the fault.
If you have a scan tool or multi meter to check these signals let me know and I will see if I can help with the testing info.
Thanks Pete
Customer: replied 2 years ago.
Hi Pete,
Just curious - why if i put the brand new resistor - i get blowing position switch and AC off. It looks like the new resistor has different schema or climat control can't recognize the new resistor. It's kinda weird - if I have good resistors (one old and two new) and i have different result when i plug them in. If they are the same the system won't be changed and have the same symptomps.
Expert:  Pete replied 2 years ago.
I apologize for the delay.
Does your model have the AUTO ac and heater controls or Manual?If it has AUTO you would have an AUTO feature on the control on the dash.
Let me know so we can continue,thanks Pete.
Customer: replied 2 years ago.

Good morning,

Nothing fancy -just manual control.

Expert:  Pete replied 2 years ago.
Good morning
Is the part number of the new resistor you installed 89019100?
Customer: replied 2 years ago.
the original part Delphi15415788. the first replacement i got from Autovalue - producer Standard, marked 14072501, the second from Canadian Tire, producer -BWD, marked 12111502.
Customer: replied 2 years ago.
Here are some links to the producer catalogs- Standard, RU377 - http://ecatalog.smpcorp.com/STD/#/vehicles/Id/227579 and BWD Part Number: RU1070 -http://www.bwdbrand.com/online%20%20catalogs-ecatalog/content.aspx. I know, all parts from China, but may be you can advice what to buy and where.
Expert:  Pete replied 2 years ago.
Hi,
I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.
Thanks Pete
Customer: replied 2 years ago.
Yes, I need help with my question. I didn't hear any useful answers... The answer - go to the dealership and buy parts there - is not a good one.
Expert:  Pete replied 2 years ago.
I apologize for the delay and the automated follow up message above.
One good component and part number for this is DORMAN Part # ***** which you can find at RockAuto.com or in the link below.You may have purchased faulty resistors causing this issue here.
https://www.rockauto.com/catalog/raframecatalog.php?ck[year_1995]=true&ck[mkt_US]=true&ck[mkt_EU]=false&ck[mkt_CA]=false&ck[mkt_MX]=false&ck[viewcurrency]=USD&ck[ID]=0&ck[idlist]=0&ck[PHP_SESSION_ID]=4ucc2jbcov76bsl06nkdr57oc0
Thanks Pete
Expert:  Pete replied 2 years ago.
Hi,
I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.
Thanks Pete
Customer: replied 2 years ago.

Hi Pete,

Just tried the new resistor from GM dealer - the same result. I need electrical schema of this control module. It's something.... If i give you my car number - is it possible to check parts compatibility exactly for this car.

Expert:  Pete replied 2 years ago.
Below is a link you can copy and paste into a new web page or web tab to view it.This should be able to help locate the issue here.
I don't have access to the break down of the exact parts from your vehicles ID but a dealers parts department will usually tell you the exact part numbers for your vehicle from your vehicle vin number at no charge.
https://www.dropbox.com/s/l42c704v59v7pmh/diag-06-12.gif?dl=0
Thanks Pete
Expert:  Pete replied 2 years ago.
Hi,

I am following up with you to see if you still needed help with your question you had asked.If my help didn't satisfy your question please let me know so we can continue.

Thanks Pete

Related GMC Questions