How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask GM Tech (Cam) Your Own Question
GM Tech (Cam)
GM Tech (Cam), GMC Mechanic
Category: GM
Satisfied Customers: 29568
Experience:  GM Grand Master Technician 2007. 14 years experience.
10949255
Type Your GM Question Here...
GM Tech (Cam) is online now
A new question is answered every 9 seconds

I have a 2006 chev 3500hd with 6.6 d-max, It wont start, i

Customer Question

hello
I have a 2006 chev 3500hd with 6.6 d-max, It wont start, i replaced glow plugs as there were 5 glow plug codes, glow plugs had been there for a few months, when truck wouldn't start, i replaced glow plugs, cleared codes and still won't start, i have done the usual replace fuel filter and bleed air by hand pumping, my scanner shows about 5000 psi injection fuel pressure while cranking, I cracked an injector line and fuel squirts while cranking. not sure where to look next.
Submitted: 2 years ago.
Category: GM
Expert:  GM Tech (Cam) replied 2 years ago.

hi there, I am Cam. Can you tell me your first name? Does your code reader show any other codes like a U1800?

Customer: replied 2 years ago.
This is Bob, I did see U1016 and U1000.Bob
Expert:  GM Tech (Cam) replied 2 years ago.

Bob, the U1016 is a loss of communications with the ECM, so what module was that set in? Is the check engine light on when you turn the key on? Do you have a chip or programmer installed?

Customer: replied 2 years ago.
engine light is on when key is turned on, There is no chip or tuner, truck is stock. this truck has some instrument cluster issues, the odometer doesn't come on with key on, for the u1016 i was trying to do some tests with my scanner and saw that, There are no current dtc's, only codes were glow plug codes and a trans module code, but since i replaced glow plugs and cleared codes there are no codes now. I figured this truck should start without glow plugs this time of year but changed the plugs anyways. if i give it a little shot of either it runs, I know not good but had to see if it would fire up.Bob
Expert:  GM Tech (Cam) replied 2 years ago.

Does it stay running then with the shot of ether or runs only on ether?

Customer: replied 2 years ago.
only runs on the either.
Expert:  GM Tech (Cam) replied 2 years ago.

Ok, for some reason the injectors are not opening. I am thinking fuel module or ECM issue. Does your scanner show a cranking rpm or engine speed?

Customer: replied 2 years ago.
no i have not seen rpm in live data, I did see cam sensor and crank sensor status, when i crank it shows ok for both,
Expert:  GM Tech (Cam) replied 2 years ago.

Also if you pump the plunger on the filter until it get stiff, does it run then even for a moment/

Customer: replied 2 years ago.
if I pump the plunger hard it doesn't even try to fire,
Expert:  GM Tech (Cam) replied 2 years ago.

After cranking for 15 seconds, does it set any codes that you can read?

How about a theft light, is that on or flashing?

I am thinking of trying a theft relearn.

Turn the key on and attempt to start the car, It may crank, it may start and stall or it may do nothing at all, this is fine, still cycle the key to start then release the key back to run.
Wait 10 minutes with the key in run. The passlock light should be flashing and the DIC will say "Service Vehicle" or "Security" or have a picture of a car with a lock during that 10 minute span.
After 10 minutes has passed, turn off the car, count to 10, and try to start it again and release the key back to run.
Wait another 10 minutes.
After 10 minutes, turn car off 10 seconds and try to start again and release the key to run.
Wait another 10 minutes.
After 10 minutes, turn car off 10 seconds and try to start again.
It should start up this time. The passlock has been learned.

During this process, turn the fans off, radio off and cycle the headlights off so the battery will not go dead. If needed, use a battery charger.

Customer: replied 2 years ago.
i will try the theft relearn in the morning, when i turn key on security lite comes on and then goes out, i have cranked 15 secs several times till it cut out and no codes set.
Expert:  GM Tech (Cam) replied 2 years ago.

Ok, try the relearn and get back to me in the morning.

Customer: replied 2 years ago.
I tried the theft relearn and no luck, I plugged in scanner and it shows 190 rpm while cranking, still no codes.
Expert:  GM Tech (Cam) replied 2 years ago.

Ok, so if you crank it a long time, what is the maximum pressure you get from the fuel rail?

Customer: replied 2 years ago.
the max i saw was 8586.9 psi after about 10 seconds.
Expert:  GM Tech (Cam) replied 2 years ago.

if you take out one glow plug and crank it, do you get any misting or smoke from the cylinder?

Expert:  GM Tech (Cam) replied 2 years ago.

Also, did you happen to get fuel right before this?

Customer: replied 2 years ago.
i will remove a glow plug and check. last fill was the day before, I checked for gas smell and there is none, I opened drain on filter ans pumped fuel into a can and fuel seemed normal.
Expert:  GM Tech (Cam) replied 2 years ago.

ok, this is concerning. Why it will not fire the injectors is strange. You have loads of pressure, great RPM, no codes, this could be injectors, this could be a ECM not firing the injector.

Expert:  GM Tech (Cam) replied 2 years ago.

I had another thought, these are prone to injection pump failures and that sends the debris out of the pump into the fuel rails blocking fuel flow.

Customer: replied 2 years ago.
I Removed glow plug and cranked engine over, no sign of any fuel, Checked compression while plug was out it is 380 psi, Checked for glow plug code and p0676 was set, So i unplugged injector and cranked engine over and it set p0206, Which all seems right to me.
Customer: replied 2 years ago.
I had checked for fuel at injector by cracking fuel line and fuel squirts out while ceanking.
Customer: replied 2 years ago.
When i was looking with scanner at live data i saw ( PTO Eng Shutdown sig. -- YES) Not sure if this means anything.
Expert:  GM Tech (Cam) replied 2 years ago.

Interesting, and you don't have a PTO, anything aftermarket?

Customer: replied 2 years ago.
There is no pto on truck, truck is stock, no add ons of any sort,
Expert:  GM Tech (Cam) replied 2 years ago.

Ok, check the wiring around the fuse block under the hood, the wiring that goes to the PCM, see if any is shorted out. If you find nothing then I think you may in fact have a bad PCM.

Customer: replied 2 years ago.
I had removed the fuse block cover and checked the wiring that goes to both computers mounted by Rad, I opened the wire loom and checked each wire. This truck ran the night before towed a trailer with lots of power, and then wouldn't start the next day.
Expert:  GM Tech (Cam) replied 2 years ago.

Lets try a reset. Take the battery cables off the battery, hold the ends together for 10 seconds then attach them to the battery and see what happens. This will reset the whole vehicle.
If you have 2 batteries, then remove both and touch only one set.

Customer: replied 2 years ago.
i just tried the reset and still no start, I had tried this yesterday, I disconnected the batteries for ten mins and then reconnected them, i didnt touch pos and neg together till today. but still no start.
Expert:  GM Tech (Cam) replied 2 years ago.

Ok so this is where it gets sticky, the GM manuals show that if it will not start with no codes, that its likely an injection pump. I don't agree. You have great pressure, just no injector firing. So it leads me to think your PCM is faulty. Why and how I am not sure, did you buy this truck new?