How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 24320
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I have a 2003 E-450 Ford walk- in delivery van with a 5.4

Customer Question

I have a 2003 E-450 Ford walk- in delivery van with a 5.4 V8.
Every time I put in gear the truck almost will stall and at idle will surge. Skips during acceleration. Changed spark plugs/coils, o2 sensors, MASS airflow sensor, ideal sensor?
Submitted: 5 months ago.
Category: Ford
Expert:  HDGENE replied 5 months ago.

Hello, and thank you for using Just Answer! My name is***** me a few moments to review your question and Ill do my best to assist you.

Expert:  HDGENE replied 5 months ago.

Hello, is the check engine light on? Any warning lights? Any diagnostic trouble codes stored that lead you to replace those parts? his is a 5.4 2 valve or a 5.4 triton 4 valve engine?

Customer: replied 5 months ago.
No check engine codes, mass flow sensor did cause the o2 sensor problems, not sure on 2 or 4 valve engine make mechanic thinks it could be the plug connectors loose going to the coil packs some were getting worn? Did a tune up back in June and changed the spark plugs, fuel filter and coils, also a vacuum line was leaking that was fixed. here is the vin# *****
Expert:  HDGENE replied 5 months ago.

O its a 2 valve modular engine, not the 3 valve triton engine. How many miles are on this engine? Is it the original fuel pump?, Fuel pressure is good? It passes Key on engine off and key on engine running tests? No misfires stored in mode 6 data when the mechanic checked using a scan tool?