How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Randall C Your Own Question
Randall C
Randall C, ASE MasterTechnician
Category: Ford
Satisfied Customers: 12891
Experience:  35 years ASE Master Tech, Diagnostic , Electrical Specialist
13677702
Type Your Ford Question Here...
Randall C is online now
A new question is answered every 9 seconds

I have a 1997 ford ranger 3.0l and I am not getting a charge

Customer Question

I have a 1997 ford ranger 3.0l and I am not getting a charge from my alternator to my battery it has a new battery in the truck and I had the alternator tested and it passed.. I'm not sure what's going on im thinking it's a wireing issue now but not sure.
Submitted: 1 month ago.
Category: Ford
Expert:  Anthony replied 1 month ago.

Hello!

Do you have a test light or a voltmeter?

Customer: replied 1 month ago.
I have both
Expert:  Anthony replied 1 month ago.

Ok, at the alternators small connector. With the key on does the yellow wire have power to ground?

Customer: replied 1 month ago.
Which connector would be considered the small connector there is 3 ports 1 is the big wire that's held on by a nut then a single wire plug and a 3 wire plug
Expert:  Anthony replied 1 month ago.

right the small yellow wire that goes to the 3 port connector does that wire have power?

Customer: replied 1 month ago.
There is a yellow wire with a white stripe and yes it has power at the alternator plug
Expert:  Anthony replied 1 month ago.

Ok, good does the big wire at the bolt lug have power too?

Customer: replied 1 month ago.
it does
Expert:  Anthony replied 1 month ago.

Who tested the alternator?

Customer: replied 1 month ago.
Orielys tested it I bought a brand new alternator and still same results
Expert:  Anthony replied 1 month ago.

Ok start the engine and tell me the voltage at the big lug again.

Customer: replied 1 month ago.
It is reading 12.1 volts the battery slowly drains when I have it running until it eventually dies
Expert:  Anthony replied 1 month ago.

So the lug at the back of the alternator reads 12.1?

Customer: replied 1 month ago.
while running
Expert:  Anthony replied 1 month ago.

Ok with it running check the yellow again. What do you get?

Customer: replied 1 month ago.
Same reading 12.1volts
Expert:  Anthony replied 1 month ago.

Check it with the 3 prong plug hooked to the alternator and it running or did you do that?

Customer: replied 1 month ago.
Yeah everything is all hooked up and plugged in and I tested the yellow wire it reads 12.1 volts while running
Expert:  Anthony replied 1 month ago.

Ok, because you just verified all the wiring is working as it should. The alternator even if its new or your original one is not working

Customer: replied 1 month ago.
I had the alternator tested and it passed I'm just not understanding why the charge is not getting to the battery I thought it is suppose to read almost 14 volts when running
Expert:  Anthony replied 1 month ago.

Does the 3 pole connector appear to be damaged in any way?

Customer: replied 1 month ago.
Plug and prongs on alternator look fine
Expert:  Anthony replied 1 month ago.

At the prong for the yellow wire does it have 12 volts?

Customer: replied 1 month ago.
It is reading 12.4 on the prong for the yellow wire
Expert:  Anthony replied 1 month ago.

Ok this is different. Start the engine. Hook one end of the voltmeter to battery negative at the battery. Hook the other end to a clean spot on the engine. The reading will be very low but I need to know exatly what it reads.

Customer: replied 1 month ago.
It went to .1 then would just read 0
Expert:  Anthony replied 1 month ago.

You have tested all of the wiring. It all passes.

Customer: replied 1 month ago.
i don't have a wiring issue? So what could cause it to not charge the battery
Expert:  Anthony replied 1 month ago.

Wiring is perfect. Even the connector. Theres nothing else to do except get a good alternator...

Expert:  Anthony replied 1 month ago.

Switch alternator brands maybe one from NAPA

Customer: replied 1 month ago.
I've had the alternator tested and it passed with the original and the 2 I bought from orielys all passed
Expert:  Randall C replied 1 month ago.

Hello, backing up, with key ON only. does the charge light come on the dash?, if so what happens after you start the engine to the light?

Customer: replied 1 month ago.
The charge light does not come on at all
Customer: replied 1 month ago.
Just a voltage gauge reading very low
Expert:  Randall C replied 1 month ago.

Did the LIGHT ever come on in the past with key on? Yours should have a light as well as a guage as you mentioned

Customer: replied 1 month ago.
The last time I drove it all of a sudden it died as the battery had drained and it right before it died it started beeping and the battery light came on
Customer: replied 1 month ago.
It's not on now but did come on when the battery drained to the point it dies
Expert:  Randall C replied 1 month ago.

so the light DID work just prior to this problem correct?

Expert:  Randall C replied 1 month ago.

I still want to reconfirm... does the light come on with key ON only, NOT started and running?

Customer: replied 1 month ago.
The truck was having this problem when I got it but when I drove it a month ago s when I did see the battery light
Customer: replied 1 month ago.
The light does not come on at all now it might if I drained the battery like what happened the last time I drove it
Expert:  Randall C replied 1 month ago.

sorrry. its important to know, forget with it running etc, go to the truck, turn key to ON only, does the light on dash come on for the battery.charging?

Customer: replied 1 month ago.
No it does not
Expert:  Randall C replied 1 month ago.

The thing is the LIGHT MUST work with key ON position only. If the buld were to fail OR the fuse for the light blow? the alternator will NOT charge, The light must work with key ON> If it is not? then need to check bulb as well as fuse # 15 a 7.5 amp fuse in the INSIDE fuse box. Lets say the fuse blew? it will NOT charge. If all is ok? then go to parts store and get a new plug assembly. They are sold aftermarket, Plugs were a big problem on these. You said you tested and changed alternator so lets rule that out, Its either the bulb? fuse for the bulb ? or the plugs which you can buy easily at most any parts store. Here is the wiring diagram link I have attached. I promise without the light working with key on? this indicates a problem with bulb or fuse and by regulator design? it will not charge unless light is in working order,. Hard to explain

Customer: replied 1 month ago.
Ok I will be pulling my dash apart tommorow to check the bulb the fuse is good
Expert:  Randall C replied 1 month ago.

sry for the delay. I would be sure you have 12 volts to the fuse and change fuse just to be sure . LMk thanks