How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask EricFromCT Your Own Question
EricFromCT
EricFromCT, Ford Technician
Category: Ford
Satisfied Customers: 3800
Experience:  20 years dealership exp., ASE A1-A9 L1 L2, Ford Lincoln Mercury Senior Master, Diesel Certified
34559540
Type Your Ford Question Here...
EricFromCT is online now
A new question is answered every 9 seconds

My 2011 Ford F-150 platinum act blower, is not working.

Customer Question

My 2011 Ford F-150 platinum act blower
JA: Are you fixing your F150 yourself? What have you tried so far?
Customer: is not working. Manual or auto. Ac in seats seem ok. Climate control
JA: Have you checked the Freon level?
Customer: modole?
JA: Anything else you want the mechanic to know before I connect you?
Customer: No
Submitted: 3 months ago.
Category: Ford
Expert:  EricFromCT replied 3 months ago.

Hi. Welcome to chat! My name is ***** ***** have been a dealer tech for 20 years. I will attempt to assist you with your concern today.

Expert:  EricFromCT replied 3 months ago.

Likely the control module has gone bad. But A lot of times resetting the battery may fix this concern as well. I would try removing the negative battery cable for a few minutes and reconnecting.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.

Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric

Customer: replied 3 months ago.
I haven't tried anything else yet. Last week it would not work but I drove into town and after about 16 minutes it came on. Worked for a couple days and nothing again.
Expert:  EricFromCT replied 3 months ago.

That does sound like poor control module performance. It still may be worth a battery reset. Hopefully will last longer then a few days. Otherwise, a control module will likely be needed. THe module does need to be programmed to the vehicle.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.

Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric

Customer: replied 3 months ago.
If I disconnect the battery does everything have to b reset. I.e. Door code exctra
Expert:  EricFromCT replied 3 months ago.

No. I dont even think you will have to reset the radio stations. But it is possible that any phones paired will have to be repaired.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.

Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric

Customer: replied 3 months ago.
Disconnected the battery no change. Put on climate control or manual. Display says fan is on high speed bot no output. R u pretty sure climate control module and not the fan motor?
Expert:  EricFromCT replied 3 months ago.

Ok. If things do not change after resetting the battery, then I would look at the blower motor or the blower motor speed controller., and assume the module is good for now. You can check the connector on the blower motor above the passenger feet. Also you can remove the speed controller, which is located near the blower motor. It is held on by 2 screws. You can inspect the board of the speed controller and check it for bubbles or burnt spots. If there are any, I would replace that first. You can also apply your own power and ground to the blower motor to make sure it works.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.

Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric

Expert:  EricFromCT replied 3 months ago.

Thank you for viewing my previous response. Please let me know if you have made progress or need more info. Otherwise please take a quick moment to rate my assistance. Thank you.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.

Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric

Expert:  EricFromCT replied 2 months ago.

Thank you for viewing my previous response. Please let me know if you have made progress or need more info. Otherwise please take a quick moment to rate my assistance. Thank you.

Please also note that rating this chat session positive will keep the chat open for further follow up questions you may have.
CLICK HERE for rating system example.
Please read this:
Understand it's not one answer and done. We can communicate back and forth many times.
1. I am an independent FACTORY DEALER auto mechanic and do not work at or for Just Answer.
2. When you're pleased or happy with my assistance or efforts to help you, at the top of the screen please rate me or reply and say "I'm satisfied".
3. Rating does not close the post and you're more than welcome to follow up.
Thanks for using Just Answer, Eric