How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 47945
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I have a 99 Ford F250 7.3 diesel. When I turn the key to

Customer Question

I have a 99 Ford F250 7.3 diesel. When I turn the key to start the truck the wait light wont come on and the truck will just crank but wont start. I have replaced the glow plug relay. Still have the same problem.
Submitted: 1 year ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 1 year ago.

Welcome, I'm Chris (aka Moose).

Check for 5 volt reference voltage to the Brown/White wire at any of the 3-wire sensors, MAP and ICP are 2 to check at. If the 5 volts is there with the key on then replace the PCM. If there is not 5 volts then we need to unplug all sensors getting 5 volts to see if one sensor is to blame. If the 5 volts never shows up then we need to cut this wire out of the PCM. If its still not there then we need to confirm all PCM powers and grounds are good. If so then the PCM is bad.

If you're confused on what to do now. You have already been charged the full question value. It's now time to compensate the tech that helped you. The only way I can continue to work here and help customers is by getting rated. If you're not pleased yet or plan not to rate me. Let me know so I can help more, close the post, or opt out. Please let me know if you're pleased with my help.

Thanks Moose.

Customer: replied 1 year ago.
What sensors, Chris your answer does not tell me what sensors. This did not help me at all sorry.
Expert:  Chris (aka- Moose) replied 1 year ago.

So I assume the first part of the test failed, you do not have 5 volts to the MAP or ICP with the key on?

Expert:  Chris (aka- Moose) replied 1 year ago.

Hello again Chris here,

I am contacting you because the post has not been closed or rated. We have 7 days to get a post rated before it times out. When a post times out, that means its no longer on my active list (if you reply I never know it.) You have already paid the fees to get this question answered, but it appears you're not pleased, or need more help.

Let me help some more. Is there anything else you feel I could offer so you would be pleased with my help. I have the option to call you if that would be better.

Thanks Chris