How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Chris (aka- Moose) Your Own Question
Chris (aka- Moose)
Chris (aka- Moose), Technician
Category: Ford
Satisfied Customers: 48617
Experience:  16 years experience
2499435
Type Your Ford Question Here...
Chris (aka- Moose) is online now
A new question is answered every 9 seconds

I am trying to install an aftermarket Kenwood double din

Customer Question

I am trying to install an aftermarket Kenwood double din radio in my 2010 ford f150 xlt (not sync or sony sound enabled), and:
JA: Have you checked the fuses?
Customer: a) new unit is getting power, just not powering on. The red reset button is blinking and now the truck won't start. I am adept at basic electrical knowledge and have the constant, power, and ground all correct
JA: Are you hoping to fix this yourself?
Customer: Yes
JA: Great! What have you tried so far?
Customer: Wiring the radio up and it didn't work. That's why I am here
JA: Is there anything else the Ford Mechanic should be aware of about your Ford?
Customer: The stock radio was working just fine. The new radio is wired with the correct harness for the 2010 model f150. I am baffled.
JA: OK. Got it. I'm sending you to a secure page on JustAnswer so you can place the $5 fully-refundable deposit now. While you're filling out that form, I'll tell the Ford Mechanic about your situation and then connect you two.
Submitted: 1 year ago.
Category: Ford
Expert:  Chris (aka- Moose) replied 1 year ago.

Welcome, I'm Chris (aka Moose).

There is not a reset button stock on for vehicles. It appears someone has installed an aftermarket immobilizer on the vehicle and this is causing the no start issue. Can you tell me the name brand of this system that has been added? Do you need a radio wiring diagram to confirm you have it wired correct?

Please make sure to select a rating from the top of your screen prior to logging off so the post does not time out.

Thanks Moose

Customer: replied 1 year ago.
The reset button is on the radio. Left the truck alone for twenty minutes, went back out, and the truck started fine. It wouldn't hurt to check against, I guess. It's pretty straightforward. I'm wondering if it's an anti-theft feature that's creating the issue.
Expert:  Chris (aka- Moose) replied 1 year ago.

Here is that wire diagram. https://dl.dropboxusercontent.com/u/90220402/10f150radio.pdf

There are no OEM wires to the radio associated with the anti theft system, though the scenario you described sounds like an anti theft system, but it does not sound like the way the Ford OEM PATS system works.

Please make sure to select a rating from the top of your screen prior to logging off so the post does not time out.

Thanks Moose

Expert:  Chris (aka- Moose) replied 1 year ago.

Hello again Chris here,

I am contacting you because the post has not been closed or rated. We have 7 days to get a post rated before it times out. When a post times out, that means its no longer on my active list (if you reply I never know it.) You have already paid the fees to get this question answered, but it appears your not pleased, or need more help.

Let me help some more. Is there anything else you feel I could offer so you would be pleased with my help. I have the option to call you if that would be better.

Thanks Chris