How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Juan Crespo Your Own Question
Juan Crespo
Juan Crespo, Tech Trainer
Category: Ford
Satisfied Customers: 1526
Experience:  A.S.E. Master Technician, Advanced Level, Emissions - Asian, Domestic, & European
19298667
Type Your Ford Question Here...
Juan Crespo is online now
A new question is answered every 9 seconds

Excursion: , I have a 6.0 with 240,000 miles on it. All

Customer Question

Hello, I have a 6.0 with 240,000 miles on it. All stock and never modified, have been doing updates as needed. Have done blue spring, ICP, HPOP, IPR, Fan Clutch, 8 injectors recently, and just had it at the dealer to replace the egr as I have been told it would be next. So since it was in for egr I had the oil cooler replaced as well. Since the repair it has not started, I towed it to another reputable shop for 6.0's for a second opinion. They started with an oil change since it was needed anyway and they tell me there is no oil getting to the filter when cranking. Could this problem have been caused by any of the repairs from the previous egr and oil cooler replacements? Just wondering if I should tow it back to Ford dealer. Thanks for any help!
Submitted: 1 year ago.
Category: Ford
Expert:  Juan Crespo replied 1 year ago.
Hi there.If the engine did not start because there was no oil in it and it happened right after the oil cooler was replaced, I would contact the shop that did the oil cooler replacement and ask them to tow the vehicle back to their facility for warranty repairs.Best Regards.