How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Ford
Satisfied Customers: 29116
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Ford Question Here...
Pete is online now
A new question is answered every 9 seconds

Zamonsky..Regarding a 08 f350 6.4 code p2291..got over 500

Customer Question

Zamonsky..Regarding a 08 f350 6.4 code p2291..got over 500 on fuel rail...trying to figure out how to find oil pressure monitor on my snap on solus ultra
JA: Thanks. Can you give me any more details about your issue?
Customer: It run fine started when cold everything..took it on a 3 hour trip left it sit for 5 days no start..pluged it in for 4 hours fired up..tried again this morning -10degress celcius no start..i have a xrt pro no cat.dpf or egr...that was installed a year ago never had any issues with it..gonna change oil and filters today once i get it started
JA: OK got it. Last thing — Ford Mechanics generally expect a deposit of about $28 to help with your type of question (you only pay if satisfied). Now I'm going to take you to a page to place a secure deposit with JustAnswer. Don't worry, this chat is saved. After that, we will finish helping you.
Submitted: 1 year ago.
Category: Ford
Expert:  Pete replied 1 year ago.

Hi my name is ***** ***** I will be happy to assist with this today.In some cases I may need more info to assist better.I apologize for any delay.

If you clear out this code does the code come right back again when this issue occurs here?

Let me know so we can continue,thanks Pete.

Customer: replied 1 year ago.
I had it pluged in for 3 hours the truck started and the code was gone..buzz tested the injectors come back good...tested glow plugs come back good..fuel rail pressure 5500-6000 at idle..i have a [email protected] xrt pro installed a year ago with a cat delet.dpf delet and an egr delet never give me no issues..im using a Solus Ultra scann tool..could this be caused by bad fuel or oil filters last change was 10000 km ago..
Customer: replied 1 year ago.
could not find oil pressure monitoring on my scan tool
Expert:  Pete replied 1 year ago.

I dont know for sure if your Solus will read the pressure or display it as some scan tools that are after market are limited to what they can display on your model.I suspect this is why you cannot see the pressure.

One common issue I have seen for this issue here is a restricted fuel filter.Low engine oil may cause this as well or a restricted engine oil filter but the fuel filter being restricted is usually the main cause.If this has not been replaced in the last 10000 km I would start with having this replaced to see if this corrects the fault here.

If more help is needed, use the reply tab to continue our conversation. If no further assistance is needed, kindly rate my service.You can rate at any time and we can continue to work on your question as this will not close out your question.Keep in mind in some cases it can be difficult to fully diagnose or help repair your vehicle without seeing it and I work on delivering the best possible answer from what I see to work with.

Thanks Pete

Customer: replied 1 year ago.
i left truck running went back out it was dead not running..changed the bottom fuel filter good..went to replace top fuel filter no fuel in bowl..left filter out turned key on no full comming into the bowl just hear a gurgaling sound
Customer: replied 1 year ago.
tried this multiple times no fuel comming into bowl
Customer: replied 1 year ago.
fuel in the tank yes 1/4 tank..sounds like the pump under the truck is trying to grab prime then releases prime
Expert:  Pete replied 1 year ago.

Was it the filter on the frame rail under the drivers side floor board that had no fuel or the other filter?

Expert:  Pete replied 1 year ago.

Is this the component sounding like its losing prime?

https://www.dropbox.com/s/766b0w80r55geyr/fd-03-01.gif?dl=0

Customer: replied 1 year ago.
the filter in the motor under the hood had no fuel..when i turn the key on i can hear the fuel pump on the rail under the driver floor board..and when i go to it when its running i open the water drain and i can hear air sucking or blowing no fuel though
Customer: replied 1 year ago.
this is the component that sounds like its lossing prime
Customer: replied 1 year ago.
That component which is under the truck below the driver seat its the pump water drain..it should push fuel up to the filter in the engine compartment...I have no full comming into the filter in the engine compartment either..
Expert:  Pete replied 1 year ago.

O.k.,this component under the frame that is doing this is most likely at fault here.Either that or there is a restricted fuel line leading to it or a restriction in the fuel tank causing the noise its making.This assembly on the frame is the HFCM which is a pump type filter.It can fail and will cause what you have going on here.I would first check for any damaged fuel lines or restrictions in the tank and if all of these are o.k. then the HFCM needs replaced on the frame rail.

Let me know if you need anything else and feel free to rate my help here.

Thanks Pete

Customer: replied 1 year ago.
Have no fuel out of high pressure fuel pump...got fuel to filter and the fuel cooler bleed them both off ..took full lines off from fuel rail on back of heads no fuel comming out of steel pipe on back of heads ..very little fuel then stops..
Customer: replied 1 year ago.
the wrench light is on the dash when key is on when i crank engine the oil can light comes on only when i crank
Expert:  Pete replied 1 year ago.

Did fuel remain in the fuel filter at the engine when you had no fuel at the pipe on the heads and/or to the injectors?

Customer: replied 1 year ago.
fuel did remain in the filter in the engine compartment..also when i press the shrader valve on the fuel cooler fuel comes out...will low oil pressure cause the high pressure pump not to pump?I pressed the fuel shut off on passanger side still nothing..is there any other switches that will cause the HPFP not to pump?
Expert:  Pete replied 1 year ago.

Ford is known for low engine oil or low oil pressure to keep the engine from starting and I do believe it disables the fuel.If you have issues with low engine oil pressure this needs resolved and should correct the fuel and no start issue here.

Thanks Pete

Customer: replied 1 year ago.
ok spent time after time bleeding the whole system..had my scan tool finally got rail pressure took a while to get there so it fired up...my rail pressure is running at the desired pressure while idle and accelerating...when i shut the truck off the rail pressure bleeds off to 0psi in about 8 seconds..when warm seems to me it takes a few more cranks then before to start or even build rail pressure.im letting it cool down to see how long it takes the rail pressure to build...Would a faulty pump seal cause this issue.....
Customer: replied 1 year ago.
there is no codes anymore...
Expert:  Pete replied 1 year ago.

I apologize for the delay.

The pressure bleeding down can be caused by a leaking seal or a leaking fuel component.If you can check over the engine for any visual leaks with any of the fuel components.If a leak is found it will need repaired.If no visual leaks are found let me know so we can continue.

Thanks Pete