How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask James Your Own Question
James
James, Ford Technician
Category: Ford
Satisfied Customers: 3630
Experience:  Ford Senior Master Tech, Ford gas and diesel expert, ASE Certified
74859263
Type Your Ford Question Here...
James is online now
A new question is answered every 9 seconds

I have a ford f250 6.0 power stroke with a hard start

Customer Question

I have a ford f250 6.0 power stroke with a hard start problem. ive sealed the high pressure system and it is holding shop pressure over night ,no leak .however it still takes over 12 to 15 seconds to start after being parked over a 20 minutes period, and even longer over night .need help.
Submitted: 1 year ago.
Category: Ford
Expert:  James replied 1 year ago.

Hello, did you replace the icp sensor and IPR valve as well?

Customer: replied 1 year ago.
I REPLACED BOTH.
Customer: replied 1 year ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Customer: replied 1 year ago.
NOTE , I PRESSURE TEST THE SYSTEM THROUGH THE IPR PORT.
Expert:  James replied 1 year ago.

I can send you a phone offer.

Customer: replied 1 year ago.
GIVE ME A FEW IDEAS, THEN IF IT IS COMPLICATED WE CAN COMMUNICATE VIA PHONE. THANKS
Expert:  James replied 1 year ago.

First it will be very helpful if you have a scan tool that can monitor vehicle data. I would see how fast icp is building to 500psi. If it builds pressure slow it could be an issue with the oil filter. If your not using an OEM oil filter and cap you will have oil draining out of the filter housing and cause a hard start. If the pump wasn't replaced itself the pump can be bad. Also checking high pressure oil leaks might only show up when the engine is hot and not cold.

Expert:  James replied 1 year ago.

Hello, can I still offer you assistance?