How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site. Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask rpmdiag Your Own Question
rpmdiag
rpmdiag, Tech and Instructor
Category: Ford
Satisfied Customers: 8153
Experience:  Since 1975
12769047
Type Your Ford Question Here...
rpmdiag is online now
A new question is answered every 9 seconds

I have a 97 t-bird runs fine until I put it in drive. had a

Customer Question

I have a 97 t-bird runs fine until I put it in drive. had a speed sensor code and replaced still does it
Submitted: 2 years ago.
Category: Ford
Customer: replied 2 years ago.
Is somebody working on an answer.
Customer: replied 2 years ago.
Posted by JustAnswer at customer's request) Hello. I would like to request the following Expert Service(s) from you: Live Phone Call. Let me know if you need more information, or send me the service offer(s) so we can proceed.
Expert:  rpmdiag replied 2 years ago.

Hi, I’m Ron and I can help you.
I have been in this business since 1975 and also teach automotive repair. I am confident
we can resolve your problem together. Please understand that I don't know your skill
level. I can't see, smell, hear, or touch the vehicle either, so it may take a few replies to
get to satisfactory results. Please be patient!
I also try to give all of the information you may need, expecting a “positive rating” in
return. I will also continue assisting you after you have rated me, if necessary. If there
is any reason I cannot get a positive rating, please let me know why “in advance”, so I
can go another direction for you. I am sorry you’re having this problem; I’ll help you
through it.

If the check engine light comes on, please have the codes read first. Another thought would be a bad power brake booster, because when you shift to drive, your foot is on the brake, enhancing a vacuum leak. Hope this helps you.

Thanks, Ron

Customer: replied 2 years ago.
The car is now stalling if i leave it in park and bring up rpms. If i rev engine to 3-4 thousand and take my foot off it the engine stalls out.
Expert:  rpmdiag replied 2 years ago.

OK, there still can be a large vacuum leak, even at the power brake booster. Please check all possible places for vacuum to be leaking and check for codes in the computer if the check engine light is coming on.

Thanks, Ron

Customer: replied 2 years ago.
Don't hear any vacuum leaks. Idles fine. What do you think about fuel filter
as i mentioned before. I had a speed sensor code and replaced the sensor. no more codes at all.
Customer: replied 2 years ago.
I checked for vacuum leaks already.
Customer: replied 2 years ago.
There is no check engine light and has never been one
Expert:  rpmdiag replied 2 years ago.

You can try testing the fuel pump pressure. next.

Ron

Ron

Customer: replied 2 years ago.
I don't have a gauge but i just pushed down on Schroeder valve and hardly anything came out with engine off
Expert:  rpmdiag replied 2 years ago.

That's not a valid test, please have it tested for accuracy so we don't waste each other's time. I'm trying to help you, and from what you just said, there is NO PRESSURE.

Thanks, Ron

Customer: replied 2 years ago.
That is correct. I'm going to pick up a gauge. After I test it I'll get back to you....Thanks,Joe
Expert:  rpmdiag replied 2 years ago.

Great, please don't forget to rate me too and I can still assist you afterwards as well.

Thanks, Ron