How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Ron Your Own Question
Ron
Ron, ASE Certified Technician
Category: Ford
Satisfied Customers: 23821
Experience:  23 years with Ford specializing in drivability and electrical and AC. Ford certs and ASE Certs
7276279
Type Your Ford Question Here...
Ron is online now
A new question is answered every 9 seconds

I HAVE TWO QUESTIONS AS TO MY 1999 EXPEDITION . FIRST THE LESSER

Customer Question

I HAVE TWO QUESTIONS AS TO MY 1999 EXPEDITION . FIRST THE LESSER OF THE T ISSUES. MY ODOMETER LIGHT DISPLAY SHUTS OFF INTERMEDIATELY WHAT IS THE PROBLEM?
THE OTHER MORE TROUBLESOME ISSUE IS THE FRONT END STARTS SHIMS AND SHAKE AT 62 TO 65 MPH. * PLEASE THE FOLLOWING WORK HAS BEEN PREFORMED.
* 3 ALINEMENTS * 2 STABILIZER BARS * INNER AND OUTER TIES RODS *RIMS INSPECTED AND TIRES ROTATED AND BALANCED TWICE *RIGHT UPPER CONTROL ARM._____ PLEASE HELP I AM GOING BROKE HERE
Submitted: 2 years ago.
Category: Ford
Customer: replied 2 years ago.
ALSO MY POWER STEERING MAKES NOISE ONLY WHEN TURNING LEFT.
Expert:  fordtechsuzukitech25 replied 2 years ago.
i have had warped rotors shake even without applying the brake, is the fluid full and or is the fluid get air bubbles in it while the noise happens, or does the fluid look like it is full of metal or aluminun
Customer: replied 2 years ago.
All fluid is good
Expert:  fordtechsuzukitech25 replied 2 years ago.
sounds like the power steering pump needs to be replaced
Customer: replied 2 years ago.
Okay so let keep going I need answers
Customer: replied 2 years ago.
OKAY WHAT ABOUT THE OTHER TWO PROBLEMS
Customer: replied 2 years ago.
Where is he I am waiting on line
Customer: replied 2 years ago.
HELLO HELLO
Expert:  fordtechsuzukitech25 replied 2 years ago.
there is allumination bulbs that go into the back of the instrument cluster, one might be loose