How JustAnswer Works:
  • Ask an Expert
    Experts are full of valuable knowledge and are ready to help with any question. Credentials confirmed by a Fortune 500 verification firm.
  • Get a Professional Answer
    Via email, text message, or notification as you wait on our site.
    Ask follow up questions if you need to.
  • 100% Satisfaction Guarantee
    Rate the answer you receive.
Ask Pete Your Own Question
Pete
Pete, Auto Service Technician
Category: Ford
Satisfied Customers: 27918
Experience:  Over 17 years diagnosing and repairing automobiles various makes and models with some training and certifications.
14928985
Type Your Ford Question Here...
Pete is online now
A new question is answered every 9 seconds

Ford Ecosport 1.5 TDCI: , I own a 1.5TDCI Ford Ecosport

Customer Question

Hi ,
I own a 1.5TDCI Ford Ecosport 2013 model. I did a remap with EGR Off and face a typical issue where in the car exhibits excessive vibration between 1600-1900 rpm ( kind of misfire) . The same tuner has done the remap for several other similar cars and has never faced such an issue , however the PCM software version on my car is something unique which they haven't worked till now , they have worked on previous and newer versions , Tuner points that it could some hardware related issue . I am totally confused now coz after numerous tries ,the issue persist . I have used Forscan tool and diagnosed during the particular rpm range , it was seen that EGR vlave is closed during all time frames . Could you please help advice how to rectify the issue .
Thanks,
Ranjith
Submitted: 2 years ago.
Category: Ford
Expert:  Pete replied 2 years ago.
My name is ***** ***** I am a professional here at Just Answer. I noticed that your question was not getting a response and thought I would see if you still need help with this.I apologize for the delay and I hope I can still assist you with this here.
My info is limited on your model here but I see no one else has responded and thought I would see if I can help here.
Most likely the software that was installed is not fully compatible with your model here causing this issue.I would have them check and see if any new software is needed either by them or a dealer to correct this fault.
Thanks Pete